SaabCentral Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
352 Posts
Discussion Starter · #1 ·
I have asked this question before, not not gotten much of a response.

I have a 97 Saab 9000 CS, low pressure turbo car. I have the ECU out of a 94 CDE auto. When I put it in my car, I get roughly 15 psi boost. However, I also get a CEL that flashes 8 times, signifying a ELCD fault.

Does this mean the ELCD is not working at the time? I'm fairly certain my ELCD works under the CS lpt ECU, don't know how to tell for certain. I just wish I could get the CEL to go away.

I have seen other posts asking the same question, but never any answers.
 

·
Registered
Joined
·
352 Posts
Discussion Starter · #3 ·
It's not automatic, my car is a 5 speed. THe ELCD is the evaporative loss condrol device. The ecu mapping isn't dependant on the transmission, other than the auto ecu was tuned down to protect the box.
 

·
Registered
Joined
·
3,721 Posts
the ecu mapping torque wise is definetly different 5spd versus auto, and there are thinsg mising from your car that the auto computer will look for to my knowledge, you really do need a 5 speed piece.

as for that cel i really dont know tho.
 

·
Registered
Joined
·
352 Posts
Discussion Starter · #6 ·
I swapped in a 96 CSE 5 spd computer and got the same cel. I guess i'm just going to have to have some other method to get boost
 

·
Registered
Joined
·
3,721 Posts
well sounds like you either need to fix the issue behind the cel, or try a 97 ecu since something may be specific to emissions stuff that year, ive only done the swap on an obd1 car.

actually now that i catch that running an obd1 ecu on your obd2 car was a horrible idea, it wreaks havoc on the emissions stuff, and causes the system to pull a vacuum on the gas tank which can be disastrous if you let it go too long.

stick to obd2 boxes.
 

·
Registered
Joined
·
1,739 Posts
Also, I think obdI is looking for one oxygen sensor when obdII is looking for two. Will mess them up, mess the mixutre and reduce boost if it will be running lean...


Klim
 

·
Registered
Joined
·
352 Posts
Discussion Starter · #9 ·
Which years were which on board diagnostics systems?

I have a 97, so it's pretty late in the model run. I'm guessing OBD-II?
 
1 - 10 of 10 Posts
Top