SaabCentral Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Hi guys, I am a beginner in DIY. I came across with a disfunctional parking light (or direction indicator) in the front left. After replacing the bulb, a bigger trouble came.

To begin with, the direction indicator didn't shine. Instead, the fron parking light works as the indicator. I got a bulb (in amber color) from Autozone and replaced it. I put some light grease too. The old bulb seems good since the filaments are okay. But the light didn't shine as well. I also dissembled the lights on the right side just to check the interior of the mounter. After put all the stuff back, I inserted the car key and all the light on the instrumental panel shined. I tried to crank, but failed. I only heard the starter click. With a couple trials, the battery was out. I jumped the car and the car cranked.

Now I see the direction indicator for turning right blink faster than usual while the one for left is normal.

Is it possible the relay for the right indicator fails? I am not familiar with how to check the relay and other stuff.

Thank you.
 

·
Registered
Joined
·
12,793 Posts
The 'flashing' function is controlled by the DICE unit, there is no 'flasher relay'
If one side of the directionals flashes quicker than the other it normally means that there is a bulb out on that side. Check all 3 bulbs on each side (front, side marker, rear).
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
Thank you, Jakejm79.
I will check the bulbs on the right, but I am wondering why the bulb would have been out. Also, it is weird that the left side flasher doesn't work even if the bulb seems Okay.

The 'flashing' function is controlled by the DICE unit, there is no 'flasher relay'
If one side of the directionals flashes quicker than the other it normally means that there is a bulb out on that side. Check all 3 bulbs on each side (front, side marker, rear).
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
I checked the bulbs, and the right front turn indicator did not work. I guess it might be caused by replacing the bulb with the "front backup" light which stays beside the turn indicator in the same unit. This light is turned on when the gear is in Reverse. It also shines when the headlight switch is at the parking light position.

I attached an image from the manual. It shows only one bulb in the unit. I don't know the official name of this "front backup light", or more information about it. The problem is really interesting that the front left turn signal indicator is out when the bulb is good.

By the way, does this "front backup light" use the same bulb as the turn signal indicator does?

Turn the hazards on and walk around the vehicle, note the lights that are out, check the bulbs first then the wiring to the light fittings.
 

Attachments

·
Registered
Joined
·
12,793 Posts
If you swapped bulbs from other positions rather than using the correct replacement bulbs then that could be your problems. Put all the bulbs back in their original position and then replace any that dont work with the correct replacement. Bringing the broken one into any autoparts store should allow you to pick the correct ones. If after replacing the bulbs they still don't work then inspect the wiring and the sockets.
 
1 - 6 of 6 Posts
Top