SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter #1
Over the last few months, the "not so trusty" 9-3 has experience electrical problems.

- starting - periodically it would not. No starter click. Removed and cleaned the key control (sorry dont know the name). It helped a bit.
- had communication errors with the steering column as per the OBD2
- ABS error

Finally I was driving along, all the warning lights in the dash lit up, the speedo dropped to zero - but it kept driving just fine.

When I stopped, it stubbornly refused to start - completely dead.

Tried the OBD2 - no readings at all.
It really seems like an electrical / communication issue.

Q1 - The next thought was to use the Tech2. I have the dongle connection, but no idea how to use the software. Is there a link for basic how-to of Tech2?

Q2 - any other ideas of basic stuff to look at?


Thanks
 

·
Registered
Joined
·
132 Posts
Discussion Starter #4 (Edited)
Quick update. I cleaned all fuses and grounds I could get my hands on. Boosted it off my other car. After a few tries, it actually fired up!!! Surprise.

Check the error codes and got:
U0212 Lost Communication With Steering Column Control Module

My previous suspicion was the Ignition Switch Module.
Would that generate such an error?

More importantly: is there a reference on how to use Tech 2 on a laptop, so I can diagnose this better?
 

·
Registered
Joined
·
1,187 Posts
Had the same problem a few weeks ago. It was a combination of the CIM, and the ABS module. You need to have a Tech II to interface everything back and to reprogram your keys. MY07 Aero was laid up for 2 weeks since there are no ABS modules in the USA, so we had to send mine out for a rebuild. Don't by one off eBay, since if the modules are not correctly 'divorced' from the doner car you can't TechII it to mate with yours.
 

·
Registered
Joined
·
278 Posts
How is the battery condition. Bad battery can cause similiar probs.


...Don't by one off eBay, since if the modules are not correctly 'divorced' from the doner car you can't TechII it to mate with yours.

Shouldn't need to divorce anything. Just have to add it with tech 2.
 

·
Registered
Joined
·
132 Posts
Discussion Starter #7
Quick update. I cleaned all fuses and grounds I could get my hands on. Boosted it off my other car. After a few tries, it actually fired up!!! Surprise.

Check the error codes and got:
U0212 Lost Communication With Steering Column Control Module

My previous suspicion was the Ignition Switch Module.
Would that generate such an error?

More importantly: is there a reference on how to use Tech 2 on a laptop, so I can diagnose this better?
Replaced the battery.
Took the old one to the refirb shop. Guy said it looked like "chocolate" after only 2 years. Guess being close to the turbo might be the issue.

With the new battery, it starts, somewhat reliably.

OBD2 says "No Link"
Dash shows ABS, brake - so guess ABS issues are next....

Above, I saw that ABS issues can prevent starting, which is kind of a dumb design. Cars have driven just fine for 100 years without ABS....
 
1 - 7 of 7 Posts
Top