SaabCentral Forums banner

1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
i drove ~250 miles yesterday and noticed at the tail end of the run that anytime i slowed or accelerated, the car would make a creaking sound, like i was driving the QEII. unfortunately i don't own the QEII so i'm a little concerned.

i read some similar posts here and it seems the suspension bushings may be at fault. i just had a new suspension put on the car less than 2,000 miles ago. could there be any other reasons for this noise? it didn't sound bad, but it was definitely atypical.

any thoughts are appreciated. thanks.
 

·
Registered
Joined
·
1,099 Posts
Bushes tend to squeak when driving over an uneven surface, speed bumps that kinda thing. An oik oik kinda sound. If you're hearing something on acceleration/deceleration then either your bushes are severly worn or the problem lies elsewhere. If I had the noise you describe and if I'd just had new suspension fitted 2k miles ago I'd be going straight back to whoever fitted the suspension to make sure everything that was supposed to be tight still is.

Bushes can be checked fairly easily for wear but rather than getting into that I think you should first get the struts etc checked out.
 
G

·
Discussion Starter · #3 ·
great thank you! i need to bring it in for an oil change so i'll def get the whole deal checked out.
 

·
Registered
Joined
·
1,099 Posts
Do you know the mechanics well where you take your car?

I can't help but have a 'glass half empty' attitude when it comes to mechanics and no doubt they'll blame the bushes or something other than the new set up just so you'll have to dip into your purse again :roll:
 
1 - 4 of 4 Posts
Top