SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3,938 Posts
Discussion Starter · #1 ·
Crank position sensor just failed on my Aero.

Symptoms were like fuel starvation.

Misfire when cold, then wouldn't start when cold.

Ran fine when warmed up. CEL came on.

My mechanic suggests these tend to last about ten years. Mine is a 97.
 

·
Registered
Joined
·
2 Posts
yea i had the same problem with my car same symptoms go ahead and replace it thier very cheap for 2nd gen 9ks mine was 300 :(

do your rpms act crazy?
 

·
Registered
Joined
·
3,938 Posts
Discussion Starter · #3 ·
When the engine was cold it idled at various rpm from 900 to about 1,500 without a pattern.


When warm it ran perfectly which was the puzzle, except for the CEL of course which meant a trip to the dealer for a code read and re-set anyway.
New sensor is being installed next week.
 

·
Registered
Joined
·
2 Posts
Superaero said:
When the engine was cold it idled at various rpm from 900 to about 1,500 without a pattern.


When warm it ran perfectly which was the puzzle, except for the CEL of course which meant a trip to the dealer for a code read and re-set anyway.
New sensor is being installed next week.
yes same happen to me but when engine got warm if shut down it wont restard

rpms did act gay when cold from .05 rmp to 2.0rpm up and down like crazy lol :) my car works like a dream now except i need a new exhuast system i have stock from 1991 i think so it has lots of holes lol
 
1 - 4 of 4 Posts
Top