SaabCentral Forums banner

21 - 30 of 30 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #21
Knowing what lights (1-5 in picture above) should be on in each of the three settings would be very helpful. Thank you so much.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #23
Hope this helps.

Number three looks to be just for the blinkers, as that is the only time they came on.
Perfect, thanks. So all my front lights are working correctly. Back to my original (and only) problem:

1. Xenon's don't auto level (they just move to the right and back during the sequence).
2. Xenon's do appear to be cornering both left and right).
3. No DTC's on Tech II
4. Cornering Light Malfunction displayed on SID.

I'm wondering if it's the AFL unit, but will check the condition of the front and rear leveling sensors first.
 

·
Registered
Joined
·
2,018 Posts
Parking light fault appears on most aftermarket scan tools for all 2008+ cars, its not real and you can disregard it, it is not connected to ur issue.
if u have no faults to go by with, check both front and rear height sensors are still attached to the control arm, if they are still attached there then report back and i will guide u from there.

im assuming you know both height sensors location!
 

·
Registered
Joined
·
7,432 Posts
You said that you have TECH2.
So connect to AFL and command headlights up/down (you can do this separately).
 

·
Registered
Joined
·
16 Posts
Discussion Starter #27
Parking light fault appears on most aftermarket scan tools for all 2008+ cars, its not real and you can disregard it, it is not connected to ur issue.
if u have no faults to go by with, check both front and rear height sensors are still attached to the control arm, if they are still attached there then report back and i will guide u from there.

im assuming you know both height sensors location!
OK, both sensors were attached. Next?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #29
I do not own a Tech2, but the place I bought it from does...but not solid on the "electrical" end of things...especially Saab. But if someone could get me detailed instructions on what to do with the Tech2 (like command the lights to go up) to try and pin point the issue, I'm sure he could figure it out.

Latest update:

1. All my front lights work as they should (except the Xenons don't level). The lights (both) just go to the right and back upon start up (they don't go up/down or left/back to center).
2. The headlights are pointed down for sure (in fail mode). About 24" height at wall...at 0" at 25 feet away.
3. Headlights do turn left and right when driving.
4. Checked the front and rear sensors...they are connected (both at the connector and at the ball joint). I moved them around to make sure they weren't seized.

I don't think it is the headlights since they both do (or don't do) the same thing (only turn right in test). So it seems that it is something that isn't sending a signal to test left and up and down...

So without knowing what the hell I'm doing, but with what I've learned so far, I think it could be:

1. Bad AFL
2. Bad sensor (front and/or rear)...or the control box for each(?).

How can I pinpoint each of these to eliminate or confirm.

Thanks for continuing to help
 

·
Registered
Joined
·
2,018 Posts
U will need a tech2 ..
may i ask u what do u mean by “moved them around to make sure they weren't seized.” What did u do exactly ???
 
21 - 30 of 30 Posts
Top