SaabCentral Forums banner
1 - 20 of 24 Posts

·
Registered
Joined
·
1,172 Posts
Discussion Starter · #1 ·
Hi Guys
I just recently aquired a 99 'verte for a cheap deal with the top in a non-functional state.
Releasing the forward latch and running the switch to retract the top gives "soft top failure" with no noise from a pump or anything. I dont know anyone with a Tech2 so it makes diagnosis a little more difficult. Is there some kind of repair manifest on first things to look for? I know we should be looking at microswitches and things like that, but I need to know the sequencing (electrically) of the retraction method so I can step by step it.
In the meantime, I have used the below methods to unlock the 5th bow and can manually open and close the top.
//JJ

Big thanks to hkayssi for the following infos:



http://www.saabcentral.com/forums/showthread.php?t=148882&highlight=tonneau+release

http://www.saabcentral.com/forums/showthread.php?t=126262

http://www.townsendimports.com/Saab_TSB_Folder/Saab_TSB_pdfs/811_2160.PDF

http://www.townsendimports.com/Saab_TSB_Folder/Saab_TSB_pdfs/811_2091.PDF

http://www.townsendimports.com/Saab_TSB_Folder/Saab_TSB_pdfs/811_2236.PDF

http://www.townsendimports.com/Saab_TSB_Folder/Saab_TSB_pdfs/811_1993.PDF

http://www.townsendimports.com/Saab_TSB_Folder/Saab_TSB_pdfs/811_2101.PDF

http://www.townsendimports.com/Saab_TSB_Folder/Saab_TSB_pdfs/811_1989.PDF

http://www.saabcentral.com/forums/showthread.php?t=100703
 

·
Registered
Joined
·
50 Posts
Have you checked the hydraulic pump behind the back seat for fluid levels? It is accessed by taking off the plate behind the seat. Remove a cover and then about eight bolts, and then you can slip the pump and integral fluid reservoir out to check, and then refill if necessary. The manual calls for a special expensive fluid, and there is a lot of discussion on this subject on this forum. My 99 vert stopped working last year, and I had low levels and I refilled it with regular hydraulic jack oil and a Lucas stop leak product(also search the files for this). No problem since, but then again, it has only been a year. make your choice if this turns out to be your problem. Mike
 

·
Registered
Joined
·
1,172 Posts
Discussion Starter · #3 ·
Yep, its right between the lines. Its the 1st thing I checked for. Unfortunately, its not even at the point where it engages the pump. It doesnt even send a signal (im guessing) to the latches to unlock the 5th bow. What I mean is there is no ATTEMPT in even trying to work. If it did, I would have a starting point at least heh.
 

·
Registered
Joined
·
12 Posts
Did you manually move the Tonneau cover unlocking lever back into the normal operating position with the jack handle after your checked everything out?
 

·
Registered
Joined
·
1,172 Posts
Discussion Starter · #5 ·
Yeah, I put everything back the way is was before to test, still no dice. What gets me is the windows dont lower by an inch nor does a pump kick in. Im downloading the WIS, hopefully something useful is in there. But Im pretty sure step 1 will involve: Connect Tech2 device..
 

·
Registered
Joined
·
1,172 Posts
Discussion Starter · #6 ·
Well, if anyone is following this thread the issue is now resolved. I brought it to a certain forum members house and plugged in the tech 2. Did a few manual latch / unlatch maneuvers for the soft top cover. Then retried. Gave a check storage code so we looked in the back, and found the microswitch for the luggage compartment disconnected. Took a paperclip, and shorted out the leads leading to the microswitches and all appears to be working now. I dont think it was just that, whatever the futzing we did with the tech 2 must have restored the sequencing as all is well now.
Thanks!
 

·
Registered
Joined
·
22 Posts
Anyone know if there is also a fluid reservoir on a 2003 9-3? Having to manually open the storage cover and then top functions. Storage cover slams shut though and didn't used to do that.
 

·
Registered
Joined
·
21,583 Posts
The newer models may use all electric rather than hydraulic.
 

·
Registered
Joined
·
389 Posts
I'm having the same problem in my car but the fulid level seems to be ok.
Yesterday I changed all four pistons due to the leaks. Now after pressing the roof button I can hear the pump noise and Soft top failure comes up. Before chaning the pistons the roof was able to fold halfway only, but it moved. Now it doesn't. Any ideas ?

I was wondering if I should make any vent procedure of the whole hydraulic installation after changing rams ? Is this possible that this could be a reason ?
 

·
Registered
Joined
·
12,793 Posts
The system is self bleeding upon several cycles of the top, you might want to raise and lower it manually a few times to see if that helps. Also the driver's (left) side rams have in built microswitches, make sure they were reconnected.
 

·
Registered
Joined
·
17 Posts
diagnostic tool

Thank you so much for the info on this forum..it helps. I am not a great car guy. limited diagnostic skill. I have a 2003 Saab 93 convertible. same as 2002 model year. The convertible top won't open. I filled the hydraulic pump. It was low. still no good. It never pops the back window portion. I hear a clicking but then nothing. Sometimes error message softop failure. sometimes a different message. I bought an AUtel md802 all systems to diagnose it, but I misinterpreted the cars covered. It covers 2003 and newer, but not the convertible. Works great on BMW...hmm.. anyway, programming might not be for me. I saw where icarsoft 906 supposedly will do all the modules for this car, about $110.00. I saw where people on this thread were buying a TECh 2 for $350.00. that may not be for me, I'm not sure I could figure out how to make it work with all the file hacking necessary. Any ideas would be appreciated. The car has other things that need attention in the body module area also.thanks
 

·
Registered
Joined
·
19,184 Posts
Make sure the handle for the valve on the pump is properly closed. It's in the manual under the emergency manual operation.

That said, I'd vote for a broken shear pin as the most likely suspect. If you goggle this group for "shear pin" you will find some photos pointing you to the location.
 

·
Registered
Joined
·
12,793 Posts
I don't think its the shear pin if the 5th bow isn't raising, the cover doesn't even unlatch till the 5th bow is vertical. Do the latches unlock the 5th bow and it just doesn't raise or does it not unlatch at all. The latching mechanism is electric and independent of the hydraulic system.
 

·
Registered
Joined
·
17 Posts
Thank you for replying..both of you. This is what I know. The top worked last year. No real problems, once in a while the top would need a gentle push or pull after an error message but then it would finish the cycle and the message would disappear. Not very often. This year it won't work. I have watched YouTube videos of the top going up and down and feel like I have the cycle correct. My top is unlatched and set free from the windshield, the windows are down, Sometimes I can hear a click at the back but the window never pops free and it appears the mechanism times out and " softop Failure" and sometimes a different message appear. I filled the hydraulic pump, never touched the valve on top. Feel like that's all good. It feels like it's electrical because nothing mechanical happens at all. if it was a bad cylinder or leak I think it would pop the window or something. Isn't the back window portion the Fifth Bow? Anyway, Saab is ok..top is up for now, but wife wants convertible!
 

·
Registered
Joined
·
658 Posts
Did you manually move the Tonneau cover unlocking lever back into the normal operating position with the jack handle after your checked everything out?
The what now?

Can you do that with the electric top too?
I cut the bag and got to the 5th bow motor that way.
 

·
Registered
Joined
·
17 Posts
I never manually worked the top or moved the valve on the hydraulic cylinder. I stuffed all 260lbs of me in the back and worked it with the top down! I never did the emergency release in the trunk.
 
1 - 20 of 24 Posts
Top