SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter #1
Hey,


When i got the car CEL p0138 and p0140 came up for o2 sensor, cleared codes - noticed poor fuel econ , ordered parts - as i am going to the shop it shut off, ran codes and a p0035 popped up, cleared codes and car started. Luckily im getting sensors changed now, is it probable that the 138/140 could cause the 035 code?

Second question, car has 170k miles its automatic, and drives fine- got the GM Trans fluid from eeuro , i understand when you drain the trans its about 30-33% of fluid, then you top up what you drained. Is one bottle enough? The mechanic said he doesn’t recommend. Whats the general consensus on such a task, i’m just being proactive.


Thanks!!!!
 

·
Registered
Joined
·
217 Posts
Discussion Starter #4
So they changed the downstream o2 sensor.

Issue that I’m getting after driving a while, is while stopped at a light the car shuts off, can’t start it up immmediatly until it cools or i unplug the battery and reconnect?

No Codes are popping up.

Any ideas??

Thanks
 

·
Registered
Joined
·
217 Posts
Discussion Starter #6
Driving back 40 miles towards last 7 miles it would jitter , kept my foot on the gas - the CE light would fade (not really flash) but would cease- luckily there wasn’t traffic, made it home and checked for codes (no CE light) and the P0035 code was in the memory.

Another post does mention the ECU.
268599
 

·
Registered
Joined
·
217 Posts
Discussion Starter #7
If indeed it’s a ECM few options i have;
1.) Get a junkyard ecm (can’t seem to find part name on car-part) and it get married to car.

2.) send it in for repair/reprograming - saw some eBay services $159-269 - seems to be the easiest?

Would appreciate any input.
 
1 - 7 of 7 Posts
Top