SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter · #1 ·
The clutch on my 02 9-3 HOT Vert is feeling a little strange.

When I push down on it as it goes past the halfway point there seems to be a little more resistance than normal, it almost feels like the cable is rubbing on something. Like a metal on metal feeling. It still works 100% and there is no slipping it just feels strange.



Any ideas?

Jules
 

·
Registered
Joined
·
21,583 Posts
South Africa , interesting place..

eEuroParts shows a hydraulic system.

The operator must feel a resistance at the 1" or so mark, this is where the TO bearing contacts the pressure plate...No man can manually depress a pressure plate without quite a bit of mechanical leverage... - unless Saab is using a "power clutch", where there is no feel..
If the resistance becomes greater than normal, then something could be fouled up - but this is hard to imagine..., particularly on a still new car...
 

·
Premium Member
Joined
·
12,576 Posts
Jules93Conv said:
When I push down on it as it goes past the halfway point there seems to be a little more resistance than normal, it almost feels like the cable is rubbing on something. Like a metal on metal feeling. It still works 100% and there is no slipping it just feels strange.
AS you have a 9-3 you shouldn't a cable clutch, you should have a hydraulic package with master & slave cylinders.

2 things before you really get concerned, try lubricating the pivot for the clutch pedal and the union to the master cylinder rod - spray grease will do; have [if has not been done recently] the clutch hydraulic circuit bled.

These two things are easy [and cheap] hits, and even if they don't totally cure your problems the car is better for the tasks anyway.
 
1 - 3 of 3 Posts
Top