SaabCentral Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
My mechanic just finished putting my Sachs ZF clutch kit and LUK DMF in along with FTE slave and GS stainless line. The clutch grabs extremely low. I mean basically a half inch to 3/4 inch off the floor. Mechanic said it will probably move up after a couple hundred miles, but wanted to check with you guys to see if this is normal?

Sent from my LM-V405 using Tapatalk
 

·
Registered
Joined
·
2,950 Posts
Not at all, they start high and then get low with milage ..
Hope he compared old with new parts and bleed the system.
 

·
Registered
Joined
·
29 Posts
I had a similar experience with my OG9-3. The clutch engaged so low I stalled it coming out of the parking space. Think it took about a week to return to the usual engagement point.
 

·
Super Moderator
Joined
·
2,983 Posts
Most likely air trapped in the system, sometimes if its in the master it will come to the surface. I've had luck leaving the clutch partially depressed overnight.
 

·
Registered
Joined
·
138 Posts
Discussion Starter #5
Thanks for the info. Gonna see how it is after about 500 miles. Gonna re-bleed if it's still real low. A note on the Sachs clutch though, this thing grabs super tight! And it's like perfect weight for me, not too heavy. I remember driving my friends g37 with a stage 2 clutch (I think Spec) and it was just completely unnecessarily heavy. I can already tell you guys that the Sachs clutch is perfect for stage 0 or 1 tunes. Maybe even more.

Sent from my LM-V405 using Tapatalk
 

·
Registered
Joined
·
138 Posts
Discussion Starter #6 (Edited)
After putting some miles on the car I feel like the clutch is getting a bit better. Will keep updating. But I do have a problem when the car is in neutral if anyone has input. I'm getting a pretty loud chattering when the pedal isn't pressed. It's very concerning to me. Is this part of break in? Will this noise go away? Also, transmission fluid was changed to redline.

Sent from my LM-V405 using Tapatalk
 

·
Registered
Joined
·
138 Posts
Discussion Starter #7
This is very odd. Was listening to the noise more in my garage. It's still happening when my foot is off the clutch. I figured out though that if I release the clutch very slowly, the noise is not audible. It's only when releasing the pedal at a normal pace. Anyone have any idea on why this could be happening?

Sent from my LM-V405 using Tapatalk
 

·
Registered
Joined
·
2,950 Posts
noise off the clutch while in neutral is usually pilot bearing, though I dont think ive seen one in saabs, just worked on couple of manual aeros in my life.
 

·
Registered
Joined
·
138 Posts
Discussion Starter #10
Just checked with my mechanic and he used redline MT85 GL4. I'm wondering if it's too thin and that's why the noise is loud? Would thicker oil quiet it down?

Sent from my LM-V405 using Tapatalk
 
1 - 10 of 10 Posts
Top