SaabCentral Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
My clutch isnt fully disengaging when i push the clutch pedal in all the way. i tried bleading the clutch, didnt work. I took the pedal off and looked at it and nothing wrong. i cant figure out why it isnt fully disengaging. This is very very frustraiting because i cant drive it and i need it for work. Does anyone know what could cause this? the clutch slave silinder looked in good condition when i took the tranny off, the clutch disk is brand new... PLEASE HELP
 

·
Registered
Joined
·
2,365 Posts
Tomholius said:
My clutch isnt fully disengaging when i push the clutch pedal in all the way. i tried bleading the clutch, didnt work. I took the pedal off and looked at it and nothing wrong. i cant figure out why it isnt fully disengaging. This is very very frustraiting because i cant drive it and i need it for work. Does anyone know what could cause this? the clutch slave silinder looked in good condition when i took the tranny off, the clutch disk is brand new... PLEASE HELP
How did you bleed it? It needs to be pressure bled.

David.
 

·
Banned
Joined
·
637 Posts
Likely your Master cylinder has failed.. Very Common, relatively inexpensive to have fixed, usually less than $200.
Ohhhh avoid 'Swedish Motorsports' at all costs.
 

·
Registered
Joined
·
2,977 Posts
Okay then, it could be either the master or slave cylinder, I changed my master cylinder first, cheapest option, it turned out to be the slave so gearbox out I'm afraid. There were no visable signs of slave cylinder failure, however putting a new one in fixed it.
 
1 - 6 of 6 Posts
Top