SaabCentral Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hi All, On my 2000 Aero estate I have a loud clunk on hard acceleration and on hard braking, always seems to be passenger side. Changed shocks and all joints/bushes except the main lower arm bushes. Would it be worth changing these to poly bushes.
Thanks
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Thanks

Hi Sean, thanks for the info, will have a look and may just order a mount and do the job. Will let you know if it cures the clunk.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Thanks for the info, will have a look at this at the weekend, I do have a quite a lot of 'suspension' rattle over rough roads.
 

·
Registered
Joined
·
417 Posts
Could easily be a motor mount--top right mount on 4cyl cars is often suspect.

I had worn subframe bushings on the rear of the subframe that were causing an odd metal to metal vibration at idle and clunking when driving. Took quite some time to pinpoint.
 

·
Registered
Joined
·
432 Posts
Yeah, my 01 9-5 LPT with 81k mi. makes all kinds of noise from the front drivers side. It sounds like something is really loose in the suspesion when I go over uneven surfaces. But, it doesnt make the sound when I hit bumps. This is what leads me to believe its not suspension related. Not sure what else to think of it. Its done it since I bought it 2 years ago, but not as bad. Now its constant and annoying. My best guess if the mount as well vs. suspension.
Im going to replace that mount first and see what happens.
 

·
Registered
Joined
·
1,875 Posts
I replaced all the mounts on the Saab, they were all toast but I never had these sounds you guys describe.

Can it be someething else?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #9 ·
At the weekend changed the passenger side engine mount and now loud clunk gone. Also air box was not near the mounts about 1/2 inch away and very close to hitting chassis, realigned this and use tyewraps to get into position and now much quieter, only got the normal front passenger side suspension rattle. Still its loads better.
 

·
Registered
Joined
·
2,035 Posts
Yeah, my 01 9-5 LPT with 81k mi. makes all kinds of noise from the front drivers side. It sounds like something is really loose in the suspesion when I go over uneven surfaces. But, it doesnt make the sound when I hit bumps. This is what leads me to believe its not suspension related. Not sure what else to think of it. Its done it since I bought it 2 years ago, but not as bad. Now its constant and annoying. My best guess if the mount as well vs. suspension.
Im going to replace that mount first and see what happens.
Best way to check is to stick a jack under the motor. Jack it up and note.... If the entire car lifts right away, the mounts are fine. If you notice the engine lift before the car starts to, its one or more engine mounts. Same can be performed on the subframe and suspension.
 
1 - 10 of 10 Posts
Top