SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
I have a manual on how to remove the fuel injectors and install them, but it doesn't say how to clean them. What is the best way? other than purchasing new ones.

I used a full bottle of Lucas Fuel system cleaner and after the tank was about empty (3/4) my car bogged down slowly started back up drove 5 mins and DONE!
I changed spark plugs thinking that was it, Nope.. I held the accelerator down and attempted to start the car, smelled a lot of gas.. any ideas on that. It is either a fuel problem why it isn't starting or i need a new distributor.

the connector wire on distributor was cut by the spool inside the dis. and i fixed it with liquid tape and epoxy. Can't find a dis. so planning on a rebuild kit instead.

anyother ideas on No start. It turns and sounds fine, just not firing up!!!
 

·
Registered
Joined
·
1,463 Posts
Are you talking about one of those big sqeeze bottles full? If so I've learned that if you use too much of that stuff it will settle to the bottom and choke the injectors. (Carb jets in my case)

If you did, you might have to get that stuff out somehow.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #3 ·
Are you talking about one of those big sqeeze bottles full? If so I've learned that if you use too much of that stuff it will settle to the bottom and choke the injectors. (Carb jets in my case)

If you did, you might have to get that stuff out somehow.
IT was a small bottle of Fuel system Cleaner 5.2 oz bottle. It said to use a whole bottle on an empty tank of gas then refill. ive used before on previous cars, but maybe thinking my fuel system was really dirty and it cleaned it good and got some crud clogged somewhere.

just want to know if this is possibly an issue. and what to look for or test?
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #4 ·
I'm not getting the tach to jump or even move at that when cranking. shouldn't it be moving when attempting to start?
 

·
Registered
Joined
·
8,923 Posts
I'm not getting the tach to jump or even move at that when cranking. shouldn't it be moving when attempting to start?
Sounds as though the wires inside the dizzy are not repaired properly, or there is a fault with the dizzy plug or wires. If the dizzy hall sensor is working the tach should jump on cranking. To clean your injectors, get them cleaned ultrasonically. Never trust anything you put in your tank apart from gas, and even then it can be dubious.
 

·
Registered
Joined
·
13,172 Posts
It is either a fuel problem why it isn't starting or i need a new distributor.
Do you have any evidence of that or are you just guessing?
Have you checked for spark?
Have you checked fuel pressure?
Diagnosis of anything at all requires an orderly process of elimination, not guessing based on smell or past experience.
I've had plenty of good luck with injector cleaner, but it won't help a bit unless you have dirty injectors. Dirty injectors are quite tricky to diagnose, and would never keep a car from starting.
What year and model is it? Based on your information, it's either a 900s or a 900 turbo; it can't be both.
 
1 - 6 of 6 Posts
Top