SaabCentral Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hey guys,

I am losing my mind over here. I have tried multiple times to add my new CIM to the car (with belonging key) but it fails everytime. I get past all the checks and questions but after that, when it's saying "Writing Configuration", it then tells me to remove key, place key, remove key, place key....3-4 times. Then it says "Add/Remove ECU Failed".

Before I tried to add new CIM, I removed the old one via tech2. I am using a new key that came with the new CIM. Battery voltage is around 12.9V while doing the programming. I have cleared all the CIM related DTCs that popped up when I replaced the CIM. What could be the issue? The Tech2 clone I'm using works as I've managed to remove and add other modules. And yes I have security access from TIS2000.

The main problem with the car is that it won't start. The lights and everything comes on but it does not crank. I've had this problem awhile and already tried replacing the SCL and ISM amongst other things, but as nothing has worked, the problem is most likely a bad CIM.

I have no idea how to move forward from this, would greatly appreciate some guidance.

The car is a 2003 NG 9-3 Aero 2.0t Sedan
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Is the key you're using new (never mated), or previously mated to the new CIM and the key is new to you?
The key came with the CIM I bought so i would assume they have been previously mated, neither of them are entirely new though, they are both in used condition but bought from quite a legit spare part site.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 · (Edited)
Could the SCL have something to do with it?

The DTC I'm trying to get rid of is B1445 01 "Trigger Circuit CIM-SCL, Open/Short to B+".

I have followed every step to fix this according to WIS which is to check cables/connections and then replace the SCL, which I did. However when i try to 'Add' the SCL, I get the same problem as with the CIM, it tells me to remove and place key multiple times then fails to add.
 
1 - 6 of 6 Posts
Top