SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
1999 OG 9-3 'vert
Joined
·
701 Posts
Discussion Starter · #1 ·
Hello,

I keep getting the "check latches" on my SID and I can see that the little plastic thing/sensor is broken on the passenger latch. The other day I took it apart but I could not get out the latch because I did not want to mess with the weatherstrip. Once I take the weatherstrip out, I cant put it back, I have to get a new one? Right? If that's the case I will go to mechanic.Also where is the best place to take my car to, since there are no more SAAB dealerships?

Another problem that I have is my ac/vent is always blowing when the car is on. I can change the direction of the air flow, or the temperature, but I can not turn it off. Even when I press "off" it looks like its off but the air keeps blowing. What can that be? Is it possible that its a connected to the "check latch" problem?

Any advice will help, I want to try to fix it and not get ripped off by mechanics.

Thank you
Alex
 

·
Registered
Joined
·
464 Posts
from the sounds of it, I think you have two unrelated problems.

did the SE's have auto climate control? If so, your problem may lurk in there. Others who have experience with this may want to chime in, as I only have the manual CC in my cars.
 

·
Registered
Joined
·
2,490 Posts
I'm not 100% positive on the lock issue, but you may be able to jam something to just make sure the sensor isn't triggered. For the weather stripping, I'm not exactly sure what weather stripping you're talking about.

As for the air vent, how much air is blowing and can you at least adjust the fant speed? Can you actually still hear the blower? The vent leaks air from the outside all the time unless you set it to recirculate.
 

·
Registered
1999 OG 9-3 'vert
Joined
·
701 Posts
Discussion Starter · #4 ·
Yes I do have a automatic AC, but what can be the problem with it?

I can hear the fan working and it is definitely blowing hard, it’s not regular air breeze going through it...Because when I take the fuse out it stops blowing... I cannot adjust the fan speed, but I can adjust whether it is hot or cold air going through, as well as the direction (just legs, windshield, etc...)...The screen tells me everything that I change like the fan speed, direction of air, if its turned off, etc…It shows me everything like its working perfectly fine, but as I said, only thing that I can control is cold/hot air, and the direction where I want it to blow air…What can it be, can it be contected to the "check latches" problem?
I am mot sure how important is this, but I get no sound from my radio either, acts like its working, but there is just ni sound...

I am talking about the weatherstrip between the windshield and the roof that I need to take out so I can take the plastic piece above the latches, so I can pull the latches out…I will post the pictures if needed?

Suggestion about the latches might work, I will try sticking something in it …As long as it doesn’t mess something up…I just or find something good to stick in there…

Thanks
 

·
Registered
Joined
·
12,793 Posts
For the fan issue, I'd look at the fan speed controller, when they go bad they are known to just leave you with a constant high speed.
You may want to hook up a TechII, the check latches message is kinda generic and can also refer to the 5th bow or torneau cover latches, there is a potentiometer on the torneau cover motor that's reading needs to match up with the when the latches for the cover are closed (and the microswitches there activated), if it's a little out of whack it can give you an error message.
 

·
Registered
Joined
·
15 Posts
Saab 900

I noticed you are in florida I use a guy in Lake Worth, FL called Saab Services who is very fair and only does Saab's.

Tom
 

·
Registered
1999 OG 9-3 'vert
Joined
·
701 Posts
Discussion Starter · #7 ·
Saab 900

Thanks turbog, but that place is like 300 miles away from me...I found one near me so I might go over there...
What I also noticed is that its not just the radio that I have no sound on, its the whole car, my blinkers blink but I don't hear them, same with the message "check latches" it pops out but I don't hear it...So its something more than just a radio...Can it be amplifier?
Ok, I will have to hook it up to tech ll somehow and see what it reads... I heard if you pres "off" and "auto" at the same time, computer gives you error messages, so I tried it and did not get any...
Also, how can I check fan speed controller?

Thanks guys
 

·
Registered
Joined
·
12,353 Posts
It sounds like the little speaker in the SID is bad. That's where the turn signal sounds and I assume the soft top chimes come from.

Some have been able to change the speaker, but others have just replaced the SID for $40-$50.

If you buy a used SID, it must have come from a vert because certain messages/tones are turned on that type of SID. Otherwise, someone with a Tech-II will need to change the SID configuration... Ron
 

·
Registered
1999 OG 9-3 'vert
Joined
·
701 Posts
Discussion Starter · #9 ·
Saab 900

It sounds like the little speaker in the SID is bad. That's where the turn signal sounds and I assume the soft top chimes come from.

Some have been able to change the speaker, but others have just replaced the SID for $40-$50.

If you buy a used SID, it must have come from a vert because certain messages/tones are turned on that type of SID. Otherwise, someone with a Tech-II will need to change the SID configuration... Ron

Do you think changing SID speaker would fix my radio problem too? I would be able to hear radio too, or that has to do with something else?
 
1 - 9 of 9 Posts
Top