SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have just replaced the turbo and cylinderhead gasket on my 2003 aero wagon. On refitting all bits, it randn for 5minutes and while searching for a leaking air pipe, I knocked the pipes for vacumn hose on inlet manifold which caused car to stall. On fitting new vacuum pipes the car would not start. The sytoms are very odd. Botth the EMS and fuel pump relays chatter like mad AND, a buzzing noise comes from the ignition coil DI pack. Having checked all the grounds for continuity and voltage to relays (under the dash) I then put new plugs in DI Pack to check spark ( assumed source of buzzing noise) and allowed them to erath to the engine cover and found that when I turned the ignition on (not past to start) the plugs produced 1 inch sparks from all four plugs onto the engine. I have tried a new DI pack, replaced the ECU but its still the same. Any suggestions?
Cheers
Charles
 

·
Registered
SAABless booo
Joined
·
2,520 Posts
If I understand what you're saying about the DIC buzzing and electrical mini lightning bolts at start up and shut down, that's normal.
Did you check any of the main ground/earth wires in the engine bay? Is the harness completely plugged in for the DIC? It could be coincidence that the relays just died and the timing is just bad timing. Did you replace the under hood relays that are buzzing? Also, are you using an actual SEM branded DIC or a no name?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks for responding quickly, much appreciated. Checked the grounds and tested continuity and its an original Saab DI. also a new battery. Checked all wiring for DI, sensors, inlet connections. Re the DI. when its fitted into head, the buzzing noise under the bonnet is from the DI, not the relays (the engine bay relays are not really an issue, as they are more for ancillaries and they aren't chattering).I have tested the continuity and power supply for the EMS and Fuel pump relays under the dash and changed v them for new ones. I am flummoxed by this fault, Any suggestions of other potential areas to look?
Cheers
Charles
 
1 - 3 of 3 Posts
Top