SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 ·
Ok The CEL came on earlier today.(I was pushing the car for a while thats when it came on)
Flashed 7 times.
What I've researched that means an adaptation run.
It's the incorrect about of air/fuel ratio.
I think I may be running lean because boost fluctuations at WOT.
So im guessing its the MAP sensor.
Any input?
Btw this happened to me a couple of weeks ago under the same conditions. Most likely will get a used map sensor because i don't have $100.
Thanks in advance guys.
 

·
Registered
Joined
·
1,220 Posts
Your right about the 7 flashes meaning that it's a fuel air mixture issue. What it is essentially telling you is that it has adjusted as far as it can go - and despite doing this for an extended period of time - it still can not get it within tolerances. Hence the flash code. In my case it is running rich (that's a whole new story) - but if your running lean there should be additional symptoms.
 

·
Registered
Joined
·
102 Posts
I am having the same problem with my saab. My rpms also struggle below 1000 and then pop up to 1000 when starting the car. I don't know whether i'm running rich or lean, but I think I may just try replacing the MAP sensor myself. Unfortunately eeuroparts doesn't have a picture of the one for my car online and I haven't really been able to find a good picture. Can somebody show me or tell me where the MAP sensor is and how easy it is to replace??

thanks:)
 
1 - 3 of 3 Posts
Top