SaabCentral Forums banner
1 - 20 of 31 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
2006 Saab 93 Aero With 2.8L V6 and Auto transmission

I couldn't tell you the actual code since it's just what I've heard from two mechanics shops now.

Okay here's the story and the problems my car is experiencing. It won't start. It says Drivetrain malfunction. Contact Saab (pretty sure that's what it's been saying). The battery is drained. It is throwing codes for the Throttle body.

Last week my car broke down with exactly the same issues as above except it eventually started. It idled really rough. It idled rough with an apparent knocking (CEL flashed). It revved by itself up to about 4k rpms. Please note the aforementioned are all different times the car was started. It did something different each time. I took it to the dealership and they informed me it threw a code for the throttle body. They replaced it and everything appeared to be fine. I was in another state when all of this happened. I drove all the way home with no apparent issues. This was late Tuesday night when I returned and it was earlier that day I picked the car back up. Come this morning my car wouldn't start and it appears it was never fixed. (back to the above paragraph).

Has anyone experienced something similar to this? I've tried searching and have found nothing and the shop where my car is thinks my car is fine. I think there is another issue that is causing the battery to drain and throw those codes. I have a bad feeling they're going to tell me to pick my car up and this may just happen again in a few days after letting it sit.

Any/all advice welcomed and VERY much appreciated.

Thanks in advance.
 

·
Registered
Joined
·
5,873 Posts
Well you have a new and strange one here--wish we could help.
Perhaps try another dealer.
 

·
Registered
Joined
·
789 Posts
Without codes we are all shooting in the dark.
 

·
Registered
Joined
·
596 Posts
if the mechanic knows the codes, ask him what they are.

Obviously the car is not fine if it dies in a couple days.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #7 ·
Obviously the car is not fine if it dies in a couple days.
I think I'd have to agree with you. ;)


The mechanic is driving the car around hooked up to Tech 2 today so based on seeing that posted here it does give me more confidence that things are moving in the right direction. I will ask the shop for the codes next time I speak to them. I was hoping someone out there would see the details I did post and maybe be able to see something familiar based on that. It looks like this may be a sort of uncommon issue which makes me a little nervous. I only got this car not too long ago and it replaced two consecutive lemons.

Thank you everyone for your responses. Really appreciate it!
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #8 ·
I just spoke to them and they didn't notate the actual codes..only that there was multiple codes including three for throttle body.
 

·
Registered
Joined
·
596 Posts
Hopefully the mechanic will write them down, so we can help you and maube him find the problem.
 

·
Registered
Joined
·
6,410 Posts
Codes are only part of the story. You need to see some data streams. Rough idle makes me interested in long term and short term fuel trims for starters.

As for 25 years experience...
Experience is no substitute for knowledge.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #13 ·
As for 25 years experience...
Experience is no substitute for knowledge.
Agreed. I was trying to be optimistic.

So they gave me the car back a couple days later and said nothing was wrong. Towed it to them yet again today with the same issue. Will ask them for the codes this time. They aren't open until Monday. Anything else I can ask them for that would help?

Thanks everyone for reading and for the input. This is very frustrating. I can't keep having someone come bring me to work hours late.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #14 ·
First time on here for a while so I figured I'd update this. The TB was replaced with a faulty TB. Car has been running like a champ ever since. They said it was rare for the TB to go bad so no one thought the replacement TB could have been bad either I guess since apparently the chances were low. Glad to have my Saab back. :)
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #15 ·
More updates on this. Car broke down again last month. They charged me $99 to say that the battery needed replaced. Bought a $180 battery with a warranty.

Flash forward a few weeks to last week. Car wouldn't start yet again. Had it jumped and it appeared to run fine. Let it run for about an hour then shut it off and went in for the night. The next day...the same thing. Only when it started this time I went straight to a car dealership to try to trade it in. I'm sick of this car. No one seems to be able to fix it. Well at the car dealership the guy went to start it (I had hoped that since it was only minutes, it'd start okay) and it didn't start...had to get it jumped. Dealership jumped me and this time it threw the same CEL's as in the past for throttle body. Ran exactly the same with a rough idle. Now they're telling me I need to get a new starter AND another new throttle body. The car just ran out of warranty so I'm paying for it this time. I likely will have to keep the car now because I also need an inspection and new brakes and I'm too negative on this thing unfortunately to ditch it. I hate this car. If I'm going to have to keep it I want the #$(#*$ to at least run.

Anyone with any advice please help.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #16 ·
Just wanted to add they are doing the TB work under warranty..but the $280 for the battery and $300 for the starter is all adding up to be a lot and not sure if this will fix it..
 

·
Registered
Joined
·
789 Posts
WHOA!WHOA!WHOA! Tell them to give power to the starter at the relay in the UEC. I havent seen ANY starters go bad on these...BUT I have SEEN and heard of V6 ECMs (ME9) going bad, causing a NO crank. If the starter cranks, then check communication with Tech2. ME9. It might be "missing on bus". If it cant be added and it makes Tech2 LOCKUP when trying to download latest software, its bad. Try to get it replaced under emissions warranty?
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #18 ·
I called them and left them a message. They were supposed to call me this morning so I could tell them what you just told me.

Any other ideas are greatly appreciated. I'm on vacation and stuck at home. :(
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #19 ·
They went ahead and installed the starter yesterday without calling me first. They also said the TB just needed "programming" and that I should get another new battery. They also said the starter isn't what was draining the battery so they pretty much admitted to not fixing anything although I'm paying $300 for it. This car has been towed 6 times for this issue. 3 of those times were to this dealership. I'm going to speak to the GM today.
 

·
Registered
Joined
·
12,355 Posts
Just curious if International Motors in Falls Church is doing the service. I'm looking at some CPO'd 9-3SS's and they have quite a few. But, based on your problems with service, I would definately like to avoid that dealer... Ron
 
1 - 20 of 31 Posts
Top