SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter · #1 ·
Hey everyone when I started my car today I was greeted with a check engine light. The Scanner at advance auto said p1452 faulty transmission pressure line, but when searching here it seems its an evap code? Also I just upgraded to a td04 and stg 1 Jzw tune on my auto box and when I laid into today the car sounded like extremely loud engine knock, but now I'm thinking it was the trans. making that noise. Car drives completely fine otherwise. 1999 2.3 auto. Thanks
 

·
Registered
Joined
·
3,951 Posts
Check the connection to the evap sensor; located under the MAF.
 

·
Registered
Joined
·
8,299 Posts
The sound would be unrelated. You have a programming issue. the 99 cars had an evap check system that was eliminated half way through the 2000 modle year. John uses a later model base map so you can get more features like open SID etc. What happens is the ECU is not checking the evap system correctly since it changed in later model years.

Just clear the code and you will be ok.

I think the sound is unrealted.
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #4 ·
Thanks for the help guys. I pulled the ecu fuse and the code hasn't returned yet. Now I just have to find the source of the awful noise.
 

·
Registered
Joined
·
8,299 Posts
It will come back tho, jsut keep clearing it. ou can check in the open sid when the evap code fisrt hits and just clear it then and you won't get a CEL.

TO keep it from going on at all ( like the week leading up to inspection) you can jsut fill your tank and not let it get below 3/4 ( or run on no more than 1/4 tanks) the ECU will only check evap on a tank between 1/4 and 3/4 full. This way you will get no cel and will pass inspection
 
1 - 5 of 5 Posts
Top