SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Factory fitted 6 CD changer in boot suddenly died today :cry: Nothing happens when I press the CD button on the radio and I don't think the boot unit is receiving power as it won't even eject the changer unit anymore. Any ideas? Have looked for a fuse for it but can't find one.
 

·
Registered
Joined
·
21,583 Posts
Check your manual for the fuse number.

There is a company that "rebuilds" these CD players....

Or you can use your test light to see if any power is running back there after doing the fuses; better yet, check the CD power from the head unit.. The WIS probably covers this a lot better..
 

·
Registered
Joined
·
138 Posts
Hello Jono, and welome to Saabcentral.

Have you had a look at the power cable that attaches to the CD player? They can work loose over a period of time,push the cable into the player and press eject to see if its just a loose connection...
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I've just tried this but no luck, pretty sure no power getting to the unit. Where does the other end of the power cable go to?
 

·
Registered
Joined
·
138 Posts
It does sound as if there's no power going to the CD player, the cable that you've just tried disappears under the carpet and runs the length of the car and into the back of the radio in the dash.
Have a look at fuse no.11 7.5 amp for the radio, and no.13 15 amp for the radio and data link connector...
 

·
Registered
Joined
·
57 Posts
I've got the same/similar thing going on. Sometimes the changer works for months at a time and sometimes it has no power. Makes me wonder about the CD changer's internals. I am going to pull the changer and look at the input connections inside the case.
 
1 - 6 of 6 Posts
Top