SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Today I replaced the motor for my driver side window. It was fairly easy to do. When I went to start my car it made a clicking sound from the engine, but did not start. The computer start up check read OK. I figured right away that the battery was low as I had the door open and the lights on when I was doing this. I then disconnected the window motor and later tried to start the car again....this is when all mayhem started.

When I turn on the highbeams I hear all types of clicking, under the passenger dash, under the driver side dash like a tommy gun and a hum from the rear of the car. No clicking from the starter anymore, no computer startup check. When I turned on the wipers my interior lights started flashing like a Christmas tree. I also noticed that the alarm light flashes like it is armed and the car seems to have some difficulty recognizing the key FOB because it takes a while to recognize the key (won't turn all of the time).

I am going to get a battery tomorrow am and try again, but my guess is that there is a short somewhere. Has anyone else experienced an issue like this?

Thanks
 

·
Super Moderator
Joined
·
9,364 Posts
Welcome to SC..

dead/low battery,you already thought this did you not put it on charge..
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
battery dead

Ok I put in a new battery this am and now car starts, but none of the drivers side controls work (windows, door locks, trunk, mirrors). I replaced the fuse for the drivers side control module and still no power...to the accessories. Funny it was working last night. Will have to pull other fuses and check if something other than the control module fuse is blown...maybe the control module itself?
 

·
Registered
Joined
·
12,509 Posts
Disconnect the batterys Neg terminal for about 5 minutes and all the computer systems will reboot. Make sure the car is off.
 
1 - 5 of 5 Posts
Top