SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
Hello All,

my car is a 94 9000 manual, new battery (2 weeks old), the car started fine yesterday and was able to drive it within the city and on the highway, drove for about 45 minutes through traffic too. then, last night as i was slowing down to park and put the car in reverse i noticed the lights flickered then the tach went to zero and the car died just as i was backing up. tried starting her up and the volts went down, it seemed to not have the power to crank the engine over.

today i noticed that it had 10.4 volts and tried to jump it with a friends car. but the same as last night the volts went down and it would not crank over. i notice that it would always go back to 9.8 - 10.4 volts after a few minutes. the windows go up and down slow, the ACC flickers like crazy, the radio works and so does the central lock. since 9 am today i've been trying to search for clues throu the forum and the manual. was looking around the engine and noticed that the CPS has one wire cut could this play into my problem? im gonna try to reconnect it.

could this be a short somewhere? the battery? or the alternator? pls help, thanks!!
 

·
Registered
Joined
·
1,036 Posts
Your alternator could be shorting out & draining your battery, after recharging & going for a run, stop & feel the alternator pulley, it will be hot if its draining

Also after a re charge, disconnect the battery over night & see what volts its got the next day i.e. maybe you,ve got a knackered cell
 

·
Registered
Joined
·
71 Posts
Discussion Starter #4
battery recharged free from autozone worked right away but alternator might be the culprit voltage went down to 12 volts and not going up while all electricals runing at full capacity, maybe time to replace the voltage regulator. thanks for the advise. :cool:
 
1 - 4 of 4 Posts
Top