SaabCentral Forums banner

1 - 11 of 11 Posts

·
Registered
2000 9-3 Aero 5d
Joined
·
639 Posts
Discussion Starter #1
So my cabin temperature sensor (next to the heated seat buttons) has now started sounding like a wind-mill/wind turbine with a 'wrrr.. faint click click sound'. Took a while to work out where the sound was comming from.

Do I need to remove it to clean it - or can I suck with a vacuum or should I get a can of compressed air and blow into it.

- I've seen a you-tube video where the user removes the blank button - pops out the ACC module - unplugs that - then removes the sensor.
Normally when I've been cleaning I've avoided it.
What's the best method? Any quick solutions?


Or is the noise sign that it needs replacing? Looking on eeuro - a new one is about USD $100. Suggestions?
 

·
Registered
Joined
·
884 Posts
The front plastic cover of the sensor pops off. If you need to remove the sensor you have to push it through the back in which case you'd want to pop out the ACC or the ashtray/tray.

You probably have a huge dust-ball in there. I'd pop off the front cover and blow it out with compressed air, maybe a cue-tip to clean it up. Some people recommend a drop of oil on the shaft although not sure if that helps or creates a dust magnet.

In any event, cleaning will most likely eliminate the noise and you should be able to clean without pulling it out.
 

·
Registered
Joined
·
10,272 Posts
Another trick, if cleaning the sensor doesn't work, is to flip it 180 degrees. Sometimes that makes it quieter, but sometimes it makes it worse. :cheesy:
 

·
Registered
Joined
·
196 Posts
Cabin sensor

I found that the dab of oil attracted dust when I tried that, blowing it out with air and wiping the shaft andtTurning it around did seem to help. I did wonder about the rubber washer type pad...if it was new...would that help. Has anyone tried replacing that/
 

·
Registered
Joined
·
10,272 Posts
If your rubber pad is hard or compressed, replacing it might help. Saab has two of them in the US. The part costs $7.59 from eSaabparts. I think mine was fairly compressed, but it didn't seem like it was enough to make hard plastic parts rattle against each other.

The 9-5 has a much better temperature sensor. It's up on the headliner and has no moving parts. Too bad that can't be retrofitted to a 9-3 or NG900.
 

·
Registered
Joined
·
2,695 Posts
I think you could probably disable the fan, either through the wiring harness or the unit itself.



I don't know what kind of "optimal" saab engineers were trying to chase, but I'm guessing it is an overkill design. Perhaps since the sensor is down low, they thought they needed to draw air in where on the 9-5 it is high where currents naturally rise.



On my dad's vert he got annoyed and stuffed something in there during a road trip, and broke the thermistor off the end. The ACC still works, and it does vary the speed of the fan etc, but it just does so blindly, and I feel too much. So worse case you could unplug your sensor and run the system in manual mode.
 

·
Registered
Joined
·
7,108 Posts
The 9-5 has a much better temperature sensor. It's up on the headliner and has no moving parts. Too bad that can't be retrofitted to a 9-3 or NG900.
9-3SS is similar - it's just a little protrusion on the dome light trim.

I bet an enterprising individual could replicate that without too much grief... but who has the time? :)
 

·
Registered
Joined
·
12,793 Posts
I think you could probably disable the fan, either through the wiring harness or the unit itself.



I don't know what kind of "optimal" saab engineers were trying to chase, but I'm guessing it is an overkill design. Perhaps since the sensor is down low, they thought they needed to draw air in where on the 9-5 it is high where currents naturally rise.



On my dad's vert he got annoyed and stuffed something in there during a road trip, and broke the thermistor off the end. The ACC still works, and it does vary the speed of the fan etc, but it just does so blindly, and I feel too much. So worse case you could unplug your sensor and run the system in manual mode.
It does need airflow in its current location, maybe if sitting higher it might not, but I've seen plenty people have jammed items in to stop the fan spinning and the don't work accurately.
I've never found one that didn't quiet down after 5 mins of disassembly, cleaning and lubing.
 

·
Registered
2000 9-3 Aero 5d
Joined
·
639 Posts
Discussion Starter #10
Thanks all. I'll try an air blow/blast - followed by a vacuum. If that doesn't work I can pop out the sensor via removing the ACC unit.
I didn't want to do that - but if its the solution and it's a simple fix I'll guess I'll have to do it.
I have 2 blank buttons - as my aero version doesn't have Traction control - That was a 2001 addition.
So it makes access to ACC easier I guess.

Side note: In trying to diagnose the noise. I thought it was coming from my Jalousie / Shift Cover.
I had only replaced that about a week ago - and I thought for a sec it was the 'green strip' vibrating against the plastic somewhere underneath.
I was also worried, I'd missed a bit of the old rubber jalousie, and it had fallen down - thus vibrating on something.
 

·
Registered
Joined
·
1,319 Posts
Cleaning is a piece of cake and usually 100% effective.

I would add to the above - the fan vanes get covered in fine dust. This doesn't stop it working but might contribute to noise. Once you have it out, might as well clean them. First I use a vac cleaner with a brush attachment, then a wet Q-tip to clean each side of each vane.

The cover comes off at the terminal end if you want o get close in to lube that end of the spindle. If oil does attract more dust it will take a long time, I would suggest.

To check resistance - across pins 2 and 3:-

10˚C : 18.5 - 21.1
20˚C : 11.7 - 13.1

Breathe on the sensor and watch the ohms change.

Remember the grille comes off rearward and the unit pushes out forward.

Doug
 
1 - 11 of 11 Posts
Top