SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter #1
07/9-3/2.0T

A/C has been blowing super cold during the past few heat waves until yesterday the fan isn’t blowing.

Upon research it could be;
1. Fuse blown/ which i hope i know on drivers door side theres a 40a orange (how can i tel thats gone?) i also heat there are other fuses to look / which would those be ?

2. Blower fan needs replacement / located behind glovebox?

Thanks!!
 

·
Super Moderator
Joined
·
20,194 Posts
I'd check fan speed control/resistor on the blower motor first.
 

·
Registered
Joined
·
8,791 Posts
1. Fuse blown/ which i hope i know on drivers door side theres a 40a orange (how can i tel thats gone?) i also heat there are other fuses to look / which would those be ?
Check with multimeter. In ohms setting, blown fuse shows OL and intact fuse shows zero.
Owners manual will tell them.
 

·
Registered
Joined
·
278 Posts
Bonus tip:


If it the fan gets wet it can seize up. Any damp carpet? If so, while you're replacing the gasket around the cabin air filter holder, reach in and spin the fan.



Double bonus tip:


Do it with the car OFF.
 

·
Registered
Joined
·
5 Posts
Excellent video here is available by searching on YouTube. I wasn't allowed to post the link because I'm still new..

I lubricated mine with some WD-40 and it worked again for a couple of weeks. I eventually bought the replacement part--which is readily available and had my local mechanic install it. Only took him about a little over an hour.

Good luck!
 

·
Registered
Joined
·
217 Posts
Discussion Starter #6
I tried swapping the 40a fuse / #23 i believe it looked burnt on tips but that didn’t resolve it.

Bought a blower fan thru a salvage yard but I think they sold me a 9-7 lol , luckily they allow returns.

Theres another yard that has one from a 2007 9-3 , heres a shot from ebay - let me know if thats the right one.

There wasn’t any water leak, checked the. Cabin air filter, however the fan i guess before seizing was making sounds.

Thanks everyone!!
 

Attachments

·
Registered
Joined
·
217 Posts
Discussion Starter #7
Resolved,,

Got part from 2011 9-3 from a local scrapyard- $65 , they even included the resistor!

Installation is a pain, took me 5 hours lol

Runs well and cold!

Youtube videos are definitely helpful but take pics along the way!

No chirping sound in the fan!

Thanks all!
 
1 - 7 of 7 Posts
Top