SaabCentral Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
427 Posts
Discussion Starter · #1 · (Edited)
I just installed my boost gauge yesterday and i took it for a test run today. when i went WOT my boost spikes to 14-15psi and hovers around 10-13psi now my question is isnt that kina high for a Stock 9-3? i got a video of it on my phone but my computer cant recognize it well i gotthe video on my facebook
 

·
Registered
Joined
·
151 Posts
Is it an SE or just the base 93, i have a 02 93 SE and when i had my boost gauge hooked up it would boost up to 14-15psi so if yours is a SE than it is normal not sure about the other models though.
 

·
Registered
Joined
·
456 Posts
Youll be fine as long as it doesnt hit 15.5psi (fuel cut)

If you want more consistant boost, clean out your BPC with some WD40 or degreaser.
 

·
Registered
Joined
·
427 Posts
Discussion Starter · #13 ·
what is BPC if u mean BPV i have a forge BOV, and i have the 5-15psi (green) spring. um from what i know the car is stock it came from a car rental place in virginia. but i do have a question i read on AEM's website a guy's gauge was reading 4 in the vac side with the engine off and when he called AEM they said it was a faulty sending unit. and mines saying the same thing so i might call them this week. I have the AEM digital boost gauge and have a few more questions about it so i might call them this week
 

·
Registered
Joined
·
427 Posts
Discussion Starter · #15 ·
o okay i have no idea what ur talkin about or wait is it by the air box and have an electric plug
 

·
Registered
Joined
·
427 Posts
Discussion Starter · #16 ·
sorry it took so long been really busy, i called AEM and they said the pressure sensor or the gauge might be bad and to send it to them and they'll thake a look. im sending it out monday, i also cleaned the BPC I hope i did it right(sprayed WD-40 ito it). will let you guys know when i get the gauge back.
 

·
Registered
Joined
·
427 Posts
Discussion Starter · #17 ·
ya i got a brand new gauge from aem and its still doing the same actually it momentarily hit 16psi in WOT 3rd and 4th gear but just for a sec and bounces back and forth between 11 and 13psi i sprayed wd40 into the bpc. any suggestions
 

·
Registered
Joined
·
751 Posts
enjoy it? try another t5 ecu see what happens, if it does the same thing = bpc, and if it dosnt do the same thing its obviosly something going on with your ecu
 

·
Registered
Joined
·
427 Posts
Discussion Starter · #19 ·
if i had another ecu i would i might be able to borrow one off a 900 would that work on my 93
 
1 - 19 of 19 Posts
Top