SaabCentral Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all.
Right after an ecu tuning upgrade ive been experiencing some boost kickback. whenever i go full throttle on my 2003 aero. its like the turbo is stopping for half a second and then it boosts up again. What do u think could be wrong????
Am sure it did not do that before the upgrade.....
 

·
Registered
Joined
·
383 Posts
The first thing that comes to mind is the Ignition Coils, they have a bad reputation on 02-04 models and the ones that come out from year models 06+ will fit our cars. Our cars have the white versions, the 06+ have the black version but it's costly. The other thing i'm thinking of is the fuel injectors, i've had that happened to me with Stage 1 so I just used regular injection cleaners additive and it went away, but that was on my car an 04 Linear 175 hp Stage 1 JZW.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
by regular injection cleaners additive u mean the ones that u put in the gas tank with the gas...?
 

·
Registered
Joined
·
2,392 Posts
What ECU upgrade did you go with? Also do you notice it at full throttle no matter what RPM range you are in? or does it do it full throttle at both low and high RPMs? A little more insight may help diagnose a little further.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
it does it on full throttle no matter what rpm. Sometimes it does on 1st gear sometimes on 2nd and last night it did it when i tried to overtake a bmw 325 on 135 kilometres per hour. the ecu upgrade was made by a german programmer in accordance with a programmer here in cyprus where i live.
 

·
Registered
Joined
·
383 Posts
I think the brand is called BearMan, not sure if that's the right way to pronounce it.
 
1 - 7 of 7 Posts
Top