SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all
Just had installed Maptun Biopower stage 6 (Forged pistons, 255 pump, 660cc injectors, Maptun XT turbo, BCPR9ES-11 plugs etc...) on 2005 9-3 2.0.
along with the new timing chain.
First start up after logging ECU using maptuner X.
Very rough at idle, excessive black smoke with strong fuel smell (running super rich or ignition is not working) and engine stalled eventually.
Hook up the tech 2 and it says 'P0340, T8 timing syncronization malfunction and no other CELs
Checked the timing again using correct tool and see no problems.
Changed the coil packs and installed new set of plugs but still no difference.

What am I missing? I'm pretty sure I'm using the correct timing tool kit as It worked fine last time.
 

·
Super Moderator
Joined
·
18,898 Posts
Are the coilpacks Saab/Mitsubishi engraved? Where did you buy them?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Coilpack is from Maptun and it’s original part. All spare parts I have is from maptun and all saab originals.
 

·
Super Moderator
Joined
·
18,898 Posts
The car and motor are 2005?
" I'm pretty sure I'm using the correct timing tool kit as It worked fine last time." Elaborate please.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I’ve used cam shaft align tool for B207R. Yes the car is 2005.
I unplugged each coil while the car was running and it didn’t die just running rough as same as before with 4 coils.
 

·
Super Moderator
Joined
·
18,898 Posts
OK, but you used that tool on that engine in that car? That's what I'm getting at. You owned this car since new so you know for a fact it has B207R motor from 2005?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7 (Edited)
Bought it back in 2007 and yes it has original 207R in it.
The original ECU died last month so put spare ECU originally from 2008 2.0 B207L motor. But I’m assuming it’s ok as I flashed it?
 
1 - 7 of 7 Posts
Top