SaabCentral Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
691 Posts
Discussion Starter · #1 ·
I have a 1997 900s and the belt keeps coming off on me. I installed the short belt mod, the belt came off, and was destroyed in 50 miles.

I put a regular, brand new Dayco belt back on, and everything seemed fine. Drove about 50 miles, and then I started the car this morning and I heard a thump.

Belt off again.

Put it back on 4 times and it kept migrating to the point where it was half on/half off the pulleys.

As car as I know there is no adjustment for this, correct? It looks like the power steering pump is off a touch, but I cant see any adjusting means.

Help!
 

·
Registered
Joined
·
130 Posts
your tensioner is suppose to keep it tight maybe you need a new one,or double check you have the belt routed proper
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #3 ·
Thanks, but it is tight- really tight- but not too tight!

The tensioner is great, and the belt is routed correctly.

What else can be the issue? How can one adjust the steering pump/whatever to keep the belt on track?
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #4 ·
I realize I made an error in my first post- it appeared that the A/C compressor was off alignment. I was right- if you losen the 2 mounting bolts, the compressor has some slop in one of the bolts and allows the pump to pivot, not much, but enough to change the attitude of the belt.

I put a pry bar under the compressor, and pryed upwards and it looked like it was spot on, I tightened the heck out of the 2 mounting bolts, put the belt back on, it looks PERFECT.

I started the car up, no more noise, I thought I had a bad idler wheel because I always had belt noise, that is gone now.

All APPEARS well now. We will see in another 50 miles.

Keep this in mind if your having belt issues folks.
 
1 - 4 of 4 Posts
Top