SaabCentral Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1 (Edited)
Im having an intermittent issue where my ACC unit shuts off and on during the first few mins of operation. It can do this wildly, or more subdued, sometimes 20 times in 2 mins, sometimes just 3-4 in 4 mins.....
...Then it works perfectly and never shuts off again.

car is 1996 Aero with 222k miles
car is daily driven

my diagnostic so far:

-I am getting power (well within the 10-16v range needed) to the ACC unit fine. (pin 22 at the wire harness i believe)...have tested this over and over shaking every wire and under any condition i can imagine...

-Ground from ACC is fine. (Pin 1 to ground location "G8")

-Fuses 1, and 17 are fine

-the relay under the hood, silver, bosch 2x15 "acc relay" is also perfectly fine. I finally found alligator clips to test it.

-Have NOT tested compressor pressure, but I do get freezing air when the acc unit stays on... (and the ACC unit will tunr off and on even in "econ" mode)

--
I am observing a few more things:

-The acc unit will shut off whether its in "ECON" mode, or "AUTO" (so calling for A/C or not)

-The ACC unit will almost always start ON when the ignition is first switched to on....(i think i may have observed it being off at start once???)

--The ACC will almost always very quickly (within a second) shut off, and then go intermittent as it wants....

--The ACC unit will be on and stay on after a few minutes or cycles....and operate perfectly afterwards. Never will it shut off after this "warmup" period.

My thoughts now are turning to a problem within the ACC unit itself (are there any capacitors inside that maybe have lost their connections? maybe once the board inside the ACC unit warms up the connection is happier, swells up and makes connection??? )

Maybe at first start there is an arcing going on that satisfies the connection, from left over residual charge from when i shut it down?

--I am hesitant just yet to open it up. My neighbor has a wrist grounding strap...I worry about SAAB saying how sensitive they are :)

So, without a known good ACC to swap....

....and hesitant to open up my own just yet

Has anyone opened these up? could I be way off that there is some wear inside causing this?

am i left to source a used one and cross my fingers?

--I will be restoring the dash, dash pad and stock radios at some point byt the bye... so will be opening it ALL up hopefully by end of summer anyhow....


With that said I am now off to remove the airbag and the stepper motor for the blend door (as it is making clicking sounds and will get itself stuck in an awkward unwanted position. like max heat the other day when it was 90 degrees out!)

hopefully i can just re-mesh its gears....


BUt with that said, any reason this issue could be related?

i was having ACC issue for about 4-6 weeks prior to the stepper motor going....


thanks all

-michael
 

·
Super Moderator
Joined
·
2,875 Posts
I'm not sure how intelligent the ACC panel is, however you've done exactly what I would do in testing for power and ground at the unit when the issue occurs. I would get a used ACC, in more modern modules if there is a short to ground on one of the components getting power from the module it will go into failsafe mode. Not sure about an 9K ACC though...
 

·
Registered
Joined
·
65 Posts
Discussion Starter #5 (Edited)
Mimmi,
My first feeling about it was either the ACC unit, or the ACC relay that you suggest replacing : under hood- multi purpose relay 2x15...

(i think i recall someone once mentioning changing that relay solved some long standing hard to diagnose issues with their ACC system)

But I did bench test the relay.... Though certainly i never did recreate situation when it was very very hot, like it was baking under hot sun under the black hood all day. -And I do have a feeling the hotter it is outside the more the issue comes up.

I guess 15 -20 bucks isn't the end of the world to give it a try...
 

·
Registered
Joined
·
65 Posts
Discussion Starter #7
Actually it looks in good shape, very clean on outisde, and again tests well when running current across it and checking for continuity.

but I have NOT opened the case up...where there might be some of the charcoal?

still think i will add a new relay to my next parts order (coming up soon) and will then take it apart to triple check.

Last two days where I am have been unseasonably cool....and i have had NO intermittent shut offs....
which continues to lead me to suspect the relay gets fussy when under the hood gets just too hot.... (assume that when cruising and driving theres enough air to cool it)

thanks mimmi,

will post when and if it gets resolved here soon.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #9
Update, not relay

Well, I have been patient and waited till i had other parts orders to put in for a new relay, which I came the other day and I installed/replaced today.

No dice. The very first start up the ACC unit blinked on and off about three or four times in first 2 minutes....

I really think its something loose in the ACC unit itself. Without a back up I am not thrilled about opening it up to check, but then again. I probably will in next week or so and see if anything can be re-soldered or touched up and if that makes any difference.

Or, try to find a cheap used one somehwere... Just spent a bunch on the 9-5 wagon.... and still not done with IT'S ACC issues (blower motor replacement tomorrow i think...if i have time, earlier this week was spent repairing blend doors on it)

when it rains it pours....

was really hoping it was the relay.

one i took out looks good on inside as well....
 

·
Registered
Joined
·
65 Posts
Discussion Starter #10 (Edited)
New (used) ACC panel unit has resolved the issue (so far, its been three days)

Ill take apart the old one that was giving me trouble soon enough and if there is anything worth noting I will do.

update:

one month and its been perfect with the new (used) acc panel

I did in fact open up the original acc panel unit and did not find any loose solder joints or anything amiss....

cest la vie.
 
1 - 10 of 10 Posts
Top