SaabCentral Forums banner
1 - 20 of 28 Posts

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #1 ·
I was trying to adapt my new gas tune and manage to do this, did multipule in a row and alsudden POP then a nice big cloud of smoke, said ***K pulled over to see this then limped home. Lucky I was able to get both part very shortly after this happened. Also blew the FPR hose off the throttle body and the C hose off the bpc, and black hose off the map sensor. Got everything back up and running and dont seem to be having any issues, just confused as to what happened, anyone got any idea what went wrong???




 

·
Registered
Joined
·
541 Posts
Same thing happened when i was running my tune for a test drive, but i have a 9-5 so mine is plastic and its held on by a ring clamp but it could have been a boost spike but who knows..
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #6 ·
Yea I was not happy, I jut want to know why this happened cuz now I'm scared to get on it again fearing it will happen again idk if it was boost bc ppl run more than me with out this happening...
 

·
Registered
Joined
·
4,335 Posts
Looks like the housing is cracked, have you had that piece off before, dropped it by accident which would cause a stress fracture? I have blown off that pipe a few times on my viggen so it's kind of normal. But breaking it is not. Get a new one from gs.
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #8 ·
I have had off before to port it don't think I dropped tho I did have a bolt with a nut on it that went all the way threw cuz I stripped the threads on the throttle body. Think that it wanted to pop off but could cuz of the nut and bolts? Btw put a nice dent in my hood where it popped off.. So you think I shouldnt be worried about it? Just a fluke??
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #15 ·
Looks like the housing is cracked, have you had that piece off before, dropped it by accident which would cause a stress fracture? I have blown off that pipe a few times on my viggen so it's kind of normal. But breaking it is not. Get a new one from gs.
Doesn't the viggen have the rubber elbow tho?
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #17 ·
I had a e85 tune before this and got another ecu tuned so I could run gas when I needed to also so if that's what it is then yes, I have the siemens #60 injectors so I had to get a custom stage 4 gas tune. Today on my way home I did try a few pulls and on one I got a big boost spike to 26 psi tho but had another pull stay at 21 and hold, so could it be bad plugs or something bpc anything??? Any input is greatly appreciated guys thanks again
Connor
 

·
Registered
Joined
·
4,335 Posts
Doesn't the viggen have the rubber elbow tho?
Yeah, I guess it is a tad different being that mine is a slip fit, and his is bolted on. But since his was cracked, pop goes the weasle. I have blown mine on the dyno twice, blown a few ic pipes off of the spg as well.
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #19 ·
Ive popped intercooler hoses off on the highway not fun but hopefully this was just a fluke but still don't know why the IAC busted open like that. Also don't know if the pipe was cracked or not before this, I guess I could of over tightened it and maybe cause a stress crack or something. Anyone know the best way to clean the IAC and what the average life span of one is?
 

·
Registered
Joined
·
556 Posts
I haven't read much of anything about IAC problems. That's probably why they cost so much.
 
1 - 20 of 28 Posts
Top