SaabCentral Forums banner

1 - 13 of 13 Posts

·
Registered
2004 Saab 9-3 1.9 tid 16v 150bhp
Joined
·
28 Posts
Discussion Starter #1
Hi all, just purchased myself a 2005 saab 1.9 tid. Love the car, great to drive (coming from a 2004 corsa 1.2 lol) but I seem to have this common problem of the radio, turn signal noise and parking sensor noise not working. I have searched Google alot about it but nothing really helps. I pulled the amp under the seat out and someone has already done the bypass, when it's plugged in there's a red light in the optical line, pulled the CD player out and there's a red light there as well. Apparently it was working but stopped when I put a battery back on the car. Checked fuse 14 and that's fine. I don't know a lot about optical systems so any help appreciated :s

Thank you :)
 

·
Registered
Joined
·
8,806 Posts
Bad amplifier under seat.
You need another amplifier, because it powers center speaker in dash.
Center speaker sounds turn signal etc warning signs.
 

·
Registered
Joined
·
283 Posts
Does the bypass not solve a bad amp?
no, it just bypasses so the optical signal continues to the other equipment. The amp would still be faulty.

I had thought that the bypass did solve the no indicator noise issue, but mimmi is fountain of knowledge, so I learned something new here.
 

·
Registered
2004 Saab 9-3 1.9 tid 16v 150bhp
Joined
·
28 Posts
Discussion Starter #5
Would the radio still not work if the amp is bypassed? Just with reduced sound quality.
 

·
Registered
Joined
·
8,806 Posts
You need TECH2 to check where is problem.
 

·
Registered
2004 Saab 9-3 1.9 tid 16v 150bhp
Joined
·
28 Posts
Discussion Starter #9
Is it possible to pull the optical cables out of the plug for the CD player and connect them (like in the amp bypass) to see if the radio works? I don't think I have onstar.
 

·
Registered
Joined
·
8,806 Posts
Yes.
Have you checked that pin 1 has red light blinking when ignition is ON (in every O-bus connectors)?
 

·
Registered
2004 Saab 9-3 1.9 tid 16v 150bhp
Joined
·
28 Posts
Discussion Starter #11
I have red light at the radio, red light at the amp and red light at the CD player. Is there anywhere else to check?
 

·
Registered
Joined
·
8,806 Posts
TECH2 tells you where is breaking point (if there is).
 

·
Registered
2004 Saab 9-3 1.9 tid 16v 150bhp
Joined
·
28 Posts
Discussion Starter #13
Just sorted it. Pulled the optical cables out of the CD player and connected them together with a piece of vacuum pipe, and radio fired into life :) also seem to have all my chimes and noises back lol. Thanks for all your help :)
 
1 - 13 of 13 Posts
Top