SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
2007 9-3 Sport Combi's AC is failing. Can anyone help with troubleshooting? Here are the details.

1. Air is warm, not cooled at all.

2. When the car starts (and AC first turns on) there is a loud hiss coming from the vents. This is NOT the sound of the blower/fan. It sounds like what you hear when you blow air into a balloon. It decreases in volume after 15 seconds but is still present quietly all the time that the AC is on. This is a new sound that was not present when the AC worked.

3. The compressor is engaging - I can see the clutch on the wheel engage and spin and, of course, stop when I turn the AC off.

4. I read the pressure on the systems low side with a gauge. It's reading about 30 psi when outside temp is about 70 F. This is when the compressor is drawing/engaged. When I shut the compressor off the static pressure on the low side jumps to about 70 psi. It seems that this is normal and I have enough R134 coolant in the system.

I don't have a full gauge set so I can't read the high pressure side of the system yet.

I am thinking that this is a case of a faulty expansion valve that is either stuck open or closed. I have easy access to the valve and it's about $40 to replace. But before I drop the cash I wanted to know if anyone had experience with this and can confirm my suspicions.

Thanks
 

·
Registered
Joined
·
568 Posts
I don't believe that there is a problem with the expansion valve. If it was stuck open the low side pressure would read higher than 30lbs as the high side pressure would not be able to build due to the stuck valve. If it was stuck closed the compressor would cycle on/off due to the high pressure.

I would prefer to see 40lbs on the low side while the compressor is running and a standing pressure of closer to 90lbs. You may just be running a bit low on R134a, imo.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
Indeed. Thanks. Charging did the trick - only a few ounces and the system went from not cooling at all to working beautifully. And that odd hissing/pressurization noise that I could hear coming from the AC vents is now gone as well.

Hopefully there isn't any significant leak in the system and this will hold. Thanks for your advice.
 
1 - 7 of 7 Posts
Top