SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I got my '99 9-3 in August up north and never really had to use the AC. Now I'm in Arizona and really need it to work, but it only blows hot air. It gets even hotter when I turn the heat on. I checked to make sure the temp switch on the dash was actually moving the switch underneath the glove box, which it was. Not sure if it has anything to do with my thermometer, which isn't working currently...
Any suggestions?
 

·
Registered
Joined
·
396 Posts
I got my '99 9-3 in August up north and never really had to use the AC. Now I'm in Arizona and really need it to work, but it only blows hot air. It gets even hotter when I turn the heat on. I checked to make sure the temp switch on the dash was actually moving the switch underneath the glove box, which it was. Not sure if it has anything to do with my thermometer, which isn't working currently...
Any suggestions?
Probably a leak somewhere in the system. Mine was the low pressure hose from the compressor. Easiest way to find out is to take it to a shop to pressure check it for leaks.
 

·
Registered
Joined
·
12,793 Posts
Make sure the AC compressor clutch engages when you press the snow flake, also make sure the low speed portion of the radiator fan works.
If the compressor clutch doesn't engage you probably have low pressure in the system, check the pressure, if low, vaccum and fill with new R134a and then monitor for leaks.
If the fan doesn't work on low mode (you can jump the low speed relay) then replace the resistor unit for the fan, details on the saab wiki.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
Already had it checked for leaks and refrigerant. Both are fine. I'm looking for an A/C wiring diagram.
 

·
Registered
Joined
·
12,353 Posts
Do you have the manual climate control or the automatic climate control?

Does the compressor engage when you turn it to cool? The compressor needs both the low pressure and high pressure sensors to activate (make internally) to switch +12 VDC to the compressor clutch... Ron
 

·
Registered
Joined
·
2,192 Posts
Does your low speed radiator fan work? I'll bet it doesn't.The problem you are having isn't a wire issue it is a pressure issue which seems to be common on these cars.
 
1 - 6 of 6 Posts
Top