SaabCentral Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
My car has suddenly lost power, there is a noise coming from the front of the engine sounding as if the exaust is blowing, but when I cover the tail pipe, i cant hear or see it blowing. the car will not rev above 4500 rpm, and the boost gauge would not go past a third of the yellow. but the engine dosent sound as if its misfireing. just lack of power.
 

·
Registered
Joined
·
4,845 Posts
joeblogs26 said:
My car has suddenly lost power, there is a noise coming from the front of the engine sounding as if the exaust is blowing, but when I cover the tail pipe, i cant hear or see it blowing. the car will not rev above 4500 rpm, and the boost gauge would not go past a third of the yellow. but the engine dosent sound as if its misfireing. just lack of power.
What do you mean "sounds as if the exhaust is blowing?" As in you can hear the exhaust in the front of the engine?

Do you have any check engine lights?

If I'm understanding you correctly, check the pipes coming off your turbo and going to and from the intercooler to the delivery pipe, and make sure the delivery pipe is on tight.
 

·
Registered
Joined
·
22,211 Posts
SectorNine50 said:
If I'm understanding you correctly, check the pipes coming off your turbo and going to and from the intercooler to the delivery pipe, and make sure the delivery pipe is on tight.
Yep sounds like a throttle body, turbo or intercooler pipe off / split :confused:
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
2002 aero lack of power.

Finaly got round to looking at car today in the freezing cold, turbo knackered, removed the turbo and split it, the exhaust vane has come off, blown a hole through the side of the exhaust side of turbo body, and now reckon I will have to take the exhuast off to get the vane out as there are no signs of the vane anywhere. gutted!!!!!! cheers for replys.
 

·
Registered
Joined
·
445 Posts
Wow how did that happen?? But sounds like you know what you are doing so at least you wont have to go to a garage. Surely the vane couldnt have travelled through 2.5 inch piping? Unless it was torn to peices, in which case it must have stopped before the cat (honeycomb bits wouldnt allow it through would they??), or did it escape through the hole in the turbo housing?Good luck!
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
the hole in the side of the turbo is only 4mm diameter. I think the vane is only 2" diameter, just trying to source a cheep turbo now.
 

·
Registered
Joined
·
4,845 Posts
Wow! This is the first time I've ever heard of this happening on a TD-04 on a Saab or a Subaru! Wonder what could have weakened it? :eek:
 

·
Registered
Joined
·
31 Posts
Discussion Starter #9
whilst looking on ebay for another turbo, found one person selling a unit, but needed repairing, said the impeller was was loose. still not help me though, need to find a cheep turbo asap, always happens at the wrong time.
 

·
Registered
Joined
·
4,845 Posts
joeblogs26 said:
whilst looking on ebay for another turbo, found one person selling a unit, but needed repairing, said the impeller was was loose. still not help me though, need to find a cheep turbo asap, always happens at the wrong time.
Have you looked on www.car-parts.com? It's basically a catalog of a bunch of wrecking yards, you might find one there.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #11
cheers mate, but need my car back on the road by this friday. miss my car badly. best car Ive had, compared to all the others cars ive had and been in.
 

·
Registered
Joined
·
4,845 Posts
joeblogs26 said:
got my turbo today, 452 pounds. gutted!!!!!!!
You bought it then gutted it? :eek: Doesn't seem very economical to me... :roll:
 

·
Registered
Joined
·
4,845 Posts
joeblogs26 said:
finaly started my car, runs perfect. Now got my car back, yahoo!!!!!
Congrats!!! :cheesy: :cool:
 
1 - 16 of 16 Posts
Top