SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
697 Posts
Discussion Starter #1
If I do an Advanced Search for (example) "tpms failure" in the NG 9-3 forum only, and sort by Relevance, the search works fine. If I try the same sorted by Date, either from the main search form or the tab on the search results page, it looks like I get most recent results for a wildcard search, nothing to do with original search term. Has anyone else seen this behavior?
 

·
Administrator
Joined
·
1,108 Posts
Nothing I have seen before, here are some details on Search from out FAQ's

Near the top of the community, you will see a search bar.

Enter a search term or phrase and click enter on your keyboard or click the magnifying glass.

Advanced Search
To narrow down search results, click on “Advanced Search” after clicking the search bar.

This will allow you to choose to search titles only, add the member username who posted it or even select a specific forum to search from.

Enter your search criteria and click “Search “ at the bottom.

You can also access advanced search by clicking the 3 vertical dots near the upper right-hand corner of the site and selecting “Advanced “Search”

Search Specific Forum
If you want to search a specific section, navigate to the forum section before entering your search term in the search bar and then select the option.

Search Specific Discussion Thread
If you want to search a specific discussion thread, navigate to it before entering your search term in the search bar and then select the option.


Jeff M
 

·
Registered
Joined
·
697 Posts
Discussion Starter #3
I understand all that. I'm still having the problem. Do you need screenshots or additional data? FWIW, I also cleared saabcentral.com cookies, with the same result.

I will try a few additional things from my end, to rule out factors like VPN.
 

·
Registered
Joined
·
697 Posts
Discussion Starter #4 (Edited)
Here is a detailed report with screenshots, all using Advanced Search. I have ruled out VPN, tracking cookie blocker, and ad blocker on my end as factors, by turning them all off. NB: All browser connections (Firefox under Linux) use SSL.

EDIT:
Firefox version:
77.0.1 (64 bit)
Linux version:
Distributor ID: Ubuntu
Description: Ubuntu 20.04 LTS
Release: 20.04 (at current patchlevel as of this post)
Codename: focal
Linux kernel version:
5.4.0-33-lowlatency #37-Ubuntu SMP PREEMPT Thu May 21 14:16:07 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Search time on Search by Date for log reference: June 5 2020 20:58 MST

Screen 1: Advanced search form before pressing Search, searching by Relevance
search1.png
Screen 2: Search results from above form. Note they are correct.
search2.png
Screen 3: Same search as Screen 1, except searching by Date.
search3.png
Screen 4: Search results from Screen 3 search. Note no matches for anything but the word "failure" in the search term. The first word of the search term appears to be ignored.
search4.png
Screen 5: Search results from Screen 2 (search results by Relevance) when selecting Most Recent from the results tab. Note same results as Screen 4.
search5.png
 

·
Administrator
Joined
·
1,108 Posts
@okcrum

Wow, thanks for the detailed steps and screenshots!

Are you still having this issue and able to reproduce as we have made some updates over the past few weeks that might have resolved this.

Ref# 172565478

Jeff M
 

·
Registered
Joined
·
697 Posts
Discussion Starter #6 (Edited)
It looks like the updates have resolved the issue.

Thanks to you and the whole team! 👍
 
1 - 6 of 6 Posts
Top