SaabCentral Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
ACC system on Auto, say 19oC. Car started cool air from vents all around, 5 minutes later fan power goes down. Another 15 minutes and fan power going up! Still cold air, this time vents to rear passengers blowing hot, very hot air :confused: .

Second problem is say a humid day. ACC on auto keeps windscreen clear. some time later windscreen starts to mist up. Switch ACC off, and then back on again screen clears. repeat every 5 minutes on a very humid day :confused: . Had several software updates and still no resolve.

Not happy any pointers would help as just bee serviced today and told oil leaks around head gasket and timing chain casing. Garage want £1450 incl. VAT :evil: !! Garage advisd that as car a 1999 model and presents itself quite well with the leather etc and is clean I take it elsewhere and trade in. Are they right? Do I call it quits before I spend money?

The £1450 is for the head gasket, timing chain (due at next service anyway) and 6 hours labour and include 10% discount.
 

·
Registered
Joined
·
5,641 Posts
I advise you to learn to operate the climate control by hand, mine seems rather dim witted as well. Saab made an amazing ECU, but the climate control could have used a little more work. :p
 

·
Registered
Joined
·
22,211 Posts
Hmm, this is a tuffy to answer, I guess I'd be thinking, what kinda car would I get for the money its worth, or would spending out make her worth keeping?

You gotta weigh up the mileage, the history, the condition plus what you have already had done etc and make up your mind, if you love her she's worth it, if not, get rid and find an Aero ;)

Oil leaks can also be a symptom of PCV failure, do you know if the PCV system is in good order?
 

·
Registered
Joined
·
11,030 Posts
Has the head gasket definately gone? Are you having overheating problems? Is it using water/oil? Is there a water/oil mix in the oil filler spout (usually looks like mayo). I'm just thinking if a head retorque would sort the problem. Re the ACC problem, have you had the system regassed? Are you getting any fault codes with a diagnostic?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Thanks for all the replies.

Head re-torque. hmmm. Took the top off this afternoon after I had borrowed a torque wrench and some bits. Found a replacement cylinder head gasket from Europart (saab didn't have any). bought a haynes manual just in case I got lost and bought a breaker bar to get that 60Nm + 90 degrees. (I middle of moving house so all tools have been in storage for last 6 months). May have helped me if the haynes manual had said I needed some female TRX sockets and what size. No friendswith any and to late to get some at this time on a Sunday.

Does anyone know what size the TRX bit needs to be. Not the easist place to get a tape measure! and I guess I'll have to buy one.

Shame really I thought I was doing quite well. 20 mins to get the top off after getting a tip from Europart to use WD40 oil to release a sticking cover. Saab suggested that they ofetn have difficulty a have to watch they don't damage cover when the prise it off!!

Regards oil leak, nothing internal so no mayo in engine just an external leak. Will get AC re-gassed when sorted the head out a got it through MOT next month.
 

·
Registered
Joined
·
18 Posts
ACC problems

I have the same ACC issue you mentioned. Cold at first and then suddenly blasts hot in the back. Or cold in front and suddenly starts turning warm, until i turn it even colder and then back to the original setting and its cool again. I was expecting to see some fault codes with it but there are none.
 

·
Registered
Joined
·
18 Posts
Ac

hmmm.... come to think of it I think it only happens with the Auto. Is that a common issue? I guess its not that big a deal but sometimes its just the small things that get to you after a while. This is my first Saab coming over from Hondas and Acuras so I was pretty accustomed to never having any problems at all.
 

·
Registered
Joined
·
11,030 Posts
I tend to select my ACC settings all the time and only change them according to the time of year. You could have a problem with the mixed air sensor under the dash though.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
For re-torque job on the head.

Camshaft cover and bits T30 and 40 male torx bits
HEad E16 female torx bit

Job took me 45 minutes from bonnet up to bonnet down - no oil leaks so far.

Interesting 1 hr 15 mins faster than saab thought
 

·
Registered
Joined
·
86 Posts
i know this has nothing to do with this problem but could some 1 help me every time i switch the car on the climate control comes on it has only started doing this since i got it back from the garage it all works fine but it is rather annoying that it comes on every time i start the car up.
 

·
Registered
Joined
·
22,211 Posts
sjfc 1884 said:
i know this has nothing to do with this problem but could some 1 help me every time i switch the car on the climate control comes on it has only started doing this since i got it back from the garage it all works fine but it is rather annoying that it comes on every time i start the car up.
You can programme it yourself , they have lost your previous settings. Mine is programmed to come on in econ mode only. Have you got your owners guide handy?:confused:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
sjfc 1884 said:
i know this has nothing to do with this problem but could some 1 help me every time i switch the car on the climate control comes on it has only started doing this since i got it back from the garage it all works fine but it is rather annoying that it comes on every time i start the car up.
Press and hold ECON button till it beeps. It should flash a couple of times afterwards. That should do it. Happens every time garage service car and do a software upgrade ~ resets software.
 

·
Registered
Joined
·
11,030 Posts
Cured?

Mawal, have we established you didn't need a head gasket just the head retorque, or is the jury still out? :roll:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #15
Kermit said:
Mawal, have we established you didn't need a head gasket just the head retorque, or is the jury still out? :roll:
Hmmm. may need some time.
of the 10 bolts 9 needed half a turn to loosen and 3/4 to tighten. 1, the last one only needed 1/4 to loosen. But it was the last one.
Still no mayo in oil, no oil on floor and the leak must be slow as no obvious loss of oil :lol: . No blue smoke but do get a smell of oil occasionally but that may be housekeeping from the job ;oops: ~ I had to use some WD40 to loosen the camshaft cover and it's probably burning off.

Car running a bit ok. perky where required :cheesy: . I'll give it a couple more weeks and post something to update on latest oil levels.

Thanks for the interest.
 
1 - 15 of 15 Posts
Top