SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Ok, so my AC has not been working for awhile and here in Michigan it has been quite warm the past couple weeks.

I finally got a can to recharge the system, took the front end apart and released the remaining pressure from the line..... good news (I hope) is that it was completely empty, hardly anything came out... time for a fresh start. Hooked the can up, recharged the system and... YAY COLD AIR COMING OUT OF THE DASH!

It was blowing pretty cool just sitting at an idle so I decided to take it for a test drive to see how it was working. It is definitely working much better than before but I noticed while driving it seemed to not be blowing as cold... and I know that is just not typically how it works. I stopped, shut the ACC off, turned it back on and got the noticeable decrease in RPMs as the motor kicked on and started blowing nice cold air out again. Driving back to my house I turned the radio and everything off and noticed that when I get on the gas and accelerate I get a whining noise coming from under the hood. Turn off the climate control and it goes away again. Any ideas what is causing this noise and not so cold of air coming out? Bad compressor, compressor clutch, belt... tensioner maybe?
 

·
Registered
Joined
·
164 Posts
I'd say the compressor sounds like it's going out. If it was clutch, usually it wouldn't switch on at all, or it would kick on and off.

I can't imagine it being the tensioner.
 
1 - 3 of 3 Posts
Top