SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
i have a quick question about my abs controller. For the longest time i thought it was bad but now my gauges are randomly working and not working. does this sound like the abs controller could be the problem or maybe an abs sensor. i thought if it was the controller that i wouldn't work until I fixed it. can they work sporadically?
 

·
Registered
Joined
·
708 Posts
According to past posts, if it is working even sporadically, someone with a tech2 should be able to communicate with it and get whatever error code is the problem for it.
Now if tech2 can't communicate with it at all, all your instruments would be down and there is someone on fleabay who actually fixes them.
Regards,
cse_20
 

·
Registered
Joined
·
54 Posts
Wheel Sensor?

When I bought my MY99 V6, the gauges were not working. After reading the boards, I thought I needed the ABD rebuild since the gauges were not working. When the CEL came on, I took it to Autozone and they gave me the code for the wheel (speed) sensor. I still sent the module off to be rebuilt.;oops:

Long story short, get the code tested. If it comes up for the wheel sensor (P0501/0502 if I remember correctly), fix that first. The indy I use charged $200 for the part and labor, and I paid close to that for the rebuild alone. At least I know that the ABS module should be OK for a while.:)

Side note...seeing as there are 2 sensors in my car (MY99 V6), my odometer "jumped" ahead to what I assume is the correct mileage after installing the new sensor.
 
1 - 3 of 3 Posts
Top