SaabCentral Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
On this 2001/9-5 I ve bunch of lights on : ABS, BRAKE, TCS...and surprisingly the speedometer or MPH gauge is dead.
Seems some electrical issue but won't know how to approach...

Help will be very much appreciated !
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #3 ·
ABS , Brake and TCS lights on

Thnx,

But wonder why speedometer is also cut off.

what kind of cost is expected for ABS rebuild ?

And what if only a wheel speed sensor fails, what kinda lights I should see on the dash ?

Thank you
 

·
Registered
Joined
·
1,267 Posts
We call it the christmas tree when it lights up the dash like that.

Rebuild is around $125. (I've seen some of their prices as low as $62)

And yes it will stop the speedo because all ABS sensors send signals to the ABS module. Those 3 lights plus no speedo = ABS module failure. If just one sensor had failed it would still read the speed from the others and just throw an ABS code.
 

·
Registered
Joined
·
2,339 Posts
Thnx,

But wonder why speedometer is also cut off.

what kind of cost is expected for ABS rebuild ?

And what if only a wheel speed sensor fails, what kinda lights I should see on the dash ?

Thank you
I'm having BBA Reman restore my ABS module right at the moment. When you take your ABS module out, you lose the speedometer, the Odometer, and the shift indicator light if your car is a manual.

My traction control light on my dash was turning on and off randomly, also my SID was saying that my car was going 15mph when it was at a complete standstill. Doing my Brake Booster anyway, so I thought, why not have the ABS rebuilt while I'm in there... The only bad part is that the cost for my '03 9-5 wagon is around $150..ouch..
 

·
Registered
Joined
·
2,339 Posts
Thnx to all ....

I now need to find out if its Bosch 5.4 or5.3 or else..?
The unit will have a barcode sticker with a set of numbers on it, ( which you will probably not see until you remove it ), just write down the series of numbers and match them to the BBA Reman Ebay auction, it will say whether it's a 5.3 version or something else..Hopefully you have a cheap one to rebuild..
 

·
Registered
Joined
·
2 Posts
ABS Related...

Related to this issue (didn't seem appropriate to start a new thread), 2 weeks ago, on my'04 9-5, I had the usual Christmas tree light up situation, loss of speedo, etc. I took out the ABS module, simple, sent it to BBA Reman, and they had it back to me incredibly quickly. I re-installed it, and when I switched on the car, the warning lights were out, voila! But when I put the car in drive and moved forward, all the warning lights came back on. :cry: Same thing has happened 2 more times. A note that came back with the part from BBA said that the warning lights may come back on because the error code may not clear for a number of driving cycles, to wait as much as a week before suspecting a continued problem. But the fact that the lights come on when the car starts rolling forward make me suspect something else is going on. Anyone have any thoughts on this?? Should I just wait out the week as BBA suggests? Thanks!
 

·
Premium Member
Joined
·
4,440 Posts
If the car drives properly and the brakes work why not just do as they suggest.

Have you cleared the codes with a scanner or a battery disconnect?
.
 

·
Registered
Joined
·
2 Posts
I had the battery disconnected for as long as it took to put the ABS module back in (30 minutes+-). Would that be enough to clear the codes?
I have not had the codes read since I don't know anyone who will read them for free. (My next step will be to look on this board for any recommendations for a good home-user code reader)
I will probably wait out the week as BBA recommended to see if the error clears before doing anything else.
If I end up not being able to figure it out, and take it to my local import mechanic, who is generally reasonable and trustworthy, he just gives me such crap for trying to do any repairs myself. He just doesn't see the 80% of work I do myself that turns out just fine.
 

·
Registered
Joined
·
7 Posts
I had the battery disconnected for as long as it took to put the ABS module back in (30 minutes+-). Would that be enough to clear the codes?
I have not had the codes read since I don't know anyone who will read them for free. (My next step will be to look on this board for any recommendations for a good home-user code reader)
I will probably wait out the week as BBA recommended to see if the error clears before doing anything else.
If I end up not being able to figure it out, and take it to my local import mechanic, who is generally reasonable and trustworthy, he just gives me such crap for trying to do any repairs myself. He just doesn't see the 80% of work I do myself that turns out just fine.
Hi, I realize that this is an old post but checking if your TCS light cleared by itself. I'm being told the same thing by BBA. Thanks.
 
1 - 13 of 13 Posts
Top