SaabCentral Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Ok we have been away in Windsor for the week when we got back home to Sheffield the Speedo Decided to let go and the ABS light came on when i started the car so i went to the AERO im breaking and took out the speed sensor from the back of the gear box drove round the block and all was good we had Speedo and abs but the as i pulled up outside the house i noted the ABS light had come back on i have searched for info on this but says it cold be the ABS module or the Alternator has anyone had this and can say its this cheers Spence :roll:
 

·
Registered
Joined
·
134 Posts
My bet would be for the ABS module. It probably needs to be rebuilt/repaired. I don't think swapping it from your Aero will work though, I'm pretty sure those are VIN/ECU specific components, which is why it will need to be rebuilt or you could have the stealer do it for a couple grand.
 

·
Registered
Joined
·
41 Posts
Sounds like your abs module, mine did the same thing a couple months ago, I grabbed one from a buddy's parts car and all is well. You can use the one from your aero, they are NOT ECU OR VIN SPECIFIC, just bolt on and go.
 

·
Registered
Joined
·
41 Posts
Nope, nothing to program or anything, just a few screws and an electrical connector and you're done. Hope I didn't come across as yelling at you or anything.
 

·
Registered
Joined
·
134 Posts
No, not at all. It's important to make sure we get the correct info here. I've got a parts car right now I'll have to try this with.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #8 ·
Thanks For your reply s i will have to look at it in the months to come as it has gone away so looks like an intermittent fault but will definitely take it off the parts car ;)
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #11 ·
Spot on, the part no. MUST match, there are several different versions of the same module depending on whether you have ESP, TCS or neither.
The car that i want to remove it from has got TCS so does this mean it wont fit
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #12 ·
And there is no speed sensor at the back of the gearbox in a 9-5.
Ok can you tell me what i have changed :roll: It had 2 wires going into one plug i put my hand down behind the battery was easy to reach i presumed it was as it is there on a 9K Aero i think ;oops:
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #14 ·
;oops:;oops:;oops:;oops:;oops:;oops: And they work beautifuly :lol: can i use the abs pump from a 2000 Aero with tcs but mine does not have it.?
 

·
Registered
Joined
·
2,037 Posts
No you cannot. Send the existing ABS module to bba-reman to have it repaired. You can not use 9k parts in the 9-5. There are only very few matching parts.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #16 ·
No you cannot. Send the existing ABS module to bba-reman to have it repaired. You can not use 9k parts in the 9-5. There are only very few matching parts.
No sorry im not breaking the 9K im breaking a 2000 95Aero would that fit sorry for any confusion
 

·
Registered
Joined
·
277 Posts
I'm having the same issue... but sometimes it's on other times it's off. Where is the ABS module located? I also have a parts car available with a known good one, I just don't know where to find it as well as the speed sensor location.
 
1 - 17 of 17 Posts
Top