SaabCentral Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi all,

First post. I got a 2007 SC and the interior lights and footwell light don't work when any of the doors open. They used to work but not anymore. I heard you remove battery and disconnect. I tried that and it worked once, but after a few days same problem.

I tried the battery trick again now but this time it did not work, nothing, still no lights.

Lights work ok with switch and the door actually lights up puddle lights (bottom of doors) all the time. But no lights inside car any more....

Arrgghhhhh

Please help a newbie..... I have searched and searched but nothing...

Cheers

Ben
 

·
Registered
Joined
·
2,208 Posts
you didnt change the function of the interior lights on the above-head console by chance? one of the settings is all off, or all on when door opens etc. could be as simple as that.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
you didnt change the function of the interior lights on the above-head console by chance? one of the settings is all off, or all on when door opens etc. could be as simple as that.
No man, switch is in correct position... That would be too easy :) thanks for reply though.... Anybody else?

Cheers

Ben
 

·
Registered
Joined
·
1,395 Posts
Isn't there a micro switch in the door that tells it the door is open or closed? In VW's they moved to an eletrical based switch versus a pin switch and when they start to go bad, they have all kinds of funky problems.....like saying when the door is open, but not that you closed it etc...


Sean
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Isn't there a micro switch in the door that tells it the door is open or closed? In VW's they moved to an eletrical based switch versus a pin switch and when they start to go bad, they have all kinds of funky problems.....like saying when the door is open, but not that you closed it etc...


Sean

Yeah I thought something like that but it does not work with ANY of the doors. So a switch in the door seems unlikely. More of a central/shared thing...

Anybody any ideas? It drives me crazy :-(

Cheers so far for suggestions... But keep them coming please :)

Cheers

Ben
 

·
Super Moderator
Joined
·
8,922 Posts
try removing the neg term off the battery for 5-10mins that normally sorts out the 9-3 electrical gremlins..
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
try removing the neg term off the battery for 5-10mins that normally sorts out the 9-3 electrical gremlins..
Yeah will give it another try but last time I tried, nothing happened. Even though it did fix it a few weeks ago.

I will keep you posted and hope that more of you reply and help me fix this **** without taking it to the stealers

Cheers

Ben
 

·
Registered
Joined
·
14 Posts
Discussion Starter #11
Done the battery thing again... still no roof lights when i open any of the doors, or take the key out...

any ideas....

Ben
 

·
Registered
Joined
·
440 Posts
if you have easy access to the Tech2, try that..i think it has a function on it to enable/disable the lights incl the courtesy lights at the doors
 

·
Registered
Joined
·
14 Posts
Discussion Starter #13
if you have easy access to the Tech2, try that..i think it has a function on it to enable/disable the lights incl the courtesy lights at the doors
Hi All,

No access to Tech2... BUT!!!!

By some form of magic, they started to work... the wife took the car out on a long drive to her grandmothers and when she came back i noticed the light was on... i asked her to turn it off... but it was working automatically again :)

so happy... but don't know why it happened...

only difference i see is that it was a long drive / the Nokia Bluetooth hands free was used... apart from that nothing..

any ideas?

Just hope they stay working....

Cheers

Ben
 
1 - 13 of 13 Posts
Top