SaabCentral Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter · #1 ·
The other day my battery died which was strange, because it started up normal that morning. anyways, i was parked side ways on the ramp of a parking stucture, at that moment I thought I was in luck and thought that I can push my car out of the parking space and let it roll down the hill and then pop the clutch. it did not work, the weird thing was that it felt like the car was on but there was no display on the SID, there was no throttle, but the power steering worked while I was still rolling. when the car finally stoped everything stop working.

I called up a buddy of mine to come and jump my car, when he came and jumped the car I received the infamous display "STEERING WHEEL LOCK MALFUNCTION" when I put the key in. it was the first time I've seen that message, I thought the battery was bad and was making the car saying weid messages, so I decided to go to the nearest Autozone to buy a replacement battery.

when I got back to the car, I replaced the battery, put the key back in the ignition and still the same display. AAARRRRGGG WTF!!

I called AAA and had them tow my car home

http://i100.photobucket.com/albums/m2/evoasian7/0130081948a.jpg
this was one of the most painful site

I searched for this problem on SC and found out that this problem is pretty common problem for 03 and 04, I've tried all possible solution that was that was mentioned and none worked, so I guess I have to get it towed to the dealer, which is almost 40 miles away;oops:

I love this car, but I hate it at the same time:lol:
 

·
Registered
Joined
·
910 Posts
Sorry to hear that, and I definitely feel your pain as this happened to me twice in my first year of ownership.

I assume you have disconnected the battery and let the car sit for 20-30 mins? After reconnecting the battery, try putting the key in and removing it to see if you can get the steering lock to disengage.

My final solution was that the dealer ended up replacing my CIM (column integration module), if this is the case I hope you are still under warranty.

They can also "reboot" your existing CIM with a Tech II device, no need to replace if you are OOW, but it could happen again in the future.

Good Luck.
 

·
Registered
Joined
·
2,539 Posts
I had mine happen on Labour day weekend, so I had my car towed on Sat. just before close and was able to muster out a rental so I could have wheels for the weekend. Imagine....a dead car just moments before the silly dealership closes for a couple days.

Anyway, it turned out to be a dead battery as it could not hold a charge. I was not charged for the battery and the dealer split the cost of the rental with me out of good faith.

Paul
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #5 ·
Alrite, right now im sittting in the waiting area of SAAB of Santa Ana, I brought my laptop and I'm bumping off of their WiFi because I might be here for awhile. they really need to put a TV in here. there is nothing but early 90's soft rock playing, and I think I'm going to kill my self

well I hope everything goes smoothly and I hope they dont blame this whole problem on my sound system I installed a week ago:roll:
 
1 - 5 of 5 Posts
Top