SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello all,

I'm a new user on the forum, so I know I have a lot to catch up on. However, I have a few problems that could probably be answered very easily. Thank you very much for help, it will be greatly appreciated.

My Car:

1999 9-3 SE w/155,000 miles.
- New DIC at 145,000 -

1. Inconsistant Idle, stalls at stop signs, stop lights, etc.

2. Seems like it is in limp mode after re-fueling, goes away after a mile or so.

3. Heater lcd is all whacked out, and heater only blows either really warm air, or really cold air.

5. Water leaks in trunk.


Anything would help, trying to hit a few birds with one stone, thanks!
 

·
Registered
Joined
·
7,876 Posts
Bowuz said:
Hello all,

I'm a new user on the forum, so I know I have a lot to catch up on. However, I have a few problems that could probably be answered very easily. Thank you very much for help, it will be greatly appreciated.

My Car:

1999 9-3 SE w/155,000 miles.
- New DIC at 145,000 -

1. Inconsistant Idle, stalls at stop signs, stop lights, etc.

2. Seems like it is in limp mode after re-fueling, goes away after a mile or so.

3. Heater lcd is all whacked out, and heater only blows either really warm air, or really cold air.

5. Water leaks in trunk.


Anything would help, trying to hit a few birds with one stone, thanks!
1-- Inconsistant Idle. Check all the vacuum hoses if any are broken or lose replace them all

2-- Limp mode after rewfueling check ther purge valve and it's hoses those tend to break too. To confirm if it's the purge valve, remove the wire harness going to it, that should correct the problem & make it run well again. If it's the purge valve clean it and lubricate it well then put it back or just simply replace it.

3-- Whacked heater lcd. Common problem. Either replace it with one from ebay or from these people
http://www.bba-reman.com/catalogue/DetailedProduct.aspx?DetailedProduct=594

For the fan speed
http://photo.platonoff.com/Auto/20060119.Saab_NG900_Fan_Speed_Control_Module/

4-- Water in the trunk
Many possibilities like the tail light gaskets leaking, The upper hatch brake light leaking, The antenna hole could be leaking or hoses from the sunroof dranage could've been knocked loose in the trunk. In rare cases (and mostly on older ng900s) it could be rusted through rear shock towers but I really doubt it's the case here
This link could be usefull for the leaks
Here's a tutorial on how to fix the leaks
http://bellsouthpwp.net/m/a/mattias.../Auto/trunk.htm

Here's how rotted shock towers look like. It's unlikely that you have that though
http://www.saabcentral.com/forums/showthread.php?p=685676#post685676
http://www.garaget.org/mypage/gallery.php?
http://www.saabcentral.com/forums/showthread.php?t=58057&highlight=rust
 

·
Registered
Joined
·
2,129 Posts
Bowuz said:
Hello all,

I'm a new user on the forum, so I know I have a lot to catch up on. However, I have a few problems that could probably be answered very easily. Thank you very much for help, it will be greatly appreciated.

My Car:

1999 9-3 SE w/155,000 miles.
- New DIC at 145,000 -

1. Inconsistant Idle, stalls at stop signs, stop lights, etc.
For #1, Clean the IAC valve and the Throttle Body. If there is gunk build up on the butterfly it will totally kill your idle. Also, check your spark plugs and regap them if needed.
 
1 - 3 of 3 Posts
Top