SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Evening...sweating it out in Boston, but not because of the heat. This is the 1st summer since having my 127K 99 9-5 engine replaced. The A/c was just tested for leaks, recharged and frosty cold....until 2hrs. later the receiver drier failed ($140.00 + 3 hr. labor...3 hrs. really????) Also the elec. are acting wierd... pulled over for gas, went to start car..nothing, no lights not even the faint click,click,click. Jumped it with a jumper box and engine started right up, but the high fan II relay was clicking away...any thoughts???? In conjunction with this the engine and all parts within the compartment are very, very hot, but the engine temp gauge is still at 1/2. The a/c problem doesn't bother me too much...makes sense that one part can go after the system is running at full pressure...but the elec. problem is bugging me...sometimes the engine starts fine...other time nothing and I just jump it. Any hints and as always thank you gang...Simon
 

·
Registered
Joined
·
22,211 Posts
Sounds like a battery problem to me :confused:
 

·
Registered
Joined
·
11,030 Posts
Agree with Chris, open each cell and check your electrolyte levels, if they are low top up with distilled water and put on charge overnight. If the levels are fine, get a shop to do a test on the battery output.
 

·
Registered
Joined
·
9 Posts
As for the temperature gauge: SAAB has it programmed to be at 9 o clock as long as the engine temperature are within safe levels once the engine is warm.

Using Tech-II, the meter can be set to display the engine temperature sensor reading without beeing filtered by software. You will then see every small temperature change.

Nervous drivers do not appreciate this setting though...
 
1 - 4 of 4 Posts
Top