SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
Yesterday out of nowhere my blower motor stopped blowing. my climate control set to auto and the bars for the fan speed were displaying full blast. This lasted for a 1/2 hour or so and then it came back on. When it is malfunctioning I still get cold air out of the vents...but only a little. If I shut off the air or put it on economy, I can hear and feel the compressor kicking in and out. So that tells me the compressor and charge are fine. Seems to be a blower / computer issue

This morning it has happened again. Has this happened to anyone else and is this possibly something I can diagnose myslef without dropping it off at the dealer?

Thanks for any help :D
 

·
Registered
Joined
·
22,211 Posts
Sounds like the ventilation fan is on its last legs - quite common I'm afraid.

Try doing a search for it ;)
 

·
Registered
Joined
·
105 Posts
I did it, it was easy. Tip: the fan is slightly flexible so to avoid gouging it on the sharp edges of it's home queeze it slightly to make it oblong and it'll slip right out.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #6 ·
Blower motor brushes was the problem!

Motor came out with no problem. Boy was it dirty, I blew the whole motor assembly out with brake cleaner and compressed air and then replaced the brushes from a local alternator repair shop. Cost me a whole $3.00

Thanks again for the point in the right direction :D
 
1 - 6 of 6 Posts
Top