SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter · #1 ·
One day out of the blue my car wouldn't start. It cranks over but just won't start. At first I suspected maybe it was my plugs, I pulled them all out and checked them all. They were all fine. Then since I had them out I might as well check the compression. I came up with 150-170-150-170. Seems normal to me. I put the plugs back in and tried to start it again. Boom! started in 2 seconds. Which leads me to believe maybe it's leaking injectors. I plan on checking them tomorrow. You think I'm on the right track?
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #2 ·
Forgot to mention, the longer the car sits the harder it is to start . After about 8 hours it won't start unless the plugs are pulled.
 

·
Registered
Joined
·
60 Posts
Got the same problem at the mo with mine - but have been having stalling issues and hesitation/misfires also but has now turned into no start.

I wish I could narrow it down for you but there are so many things it could be. I am going to go pull my plugs now though - if mine then starts too I will let you know!

Does your fuel pump prime for 3 secs when you first turn the key?

Cheers,
Si.
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #4 ·
I cant really hear the fuel pump, but I sprayed starter fluid into the throttle body and it didn't start ruling that out. I just went out to start it and it fired right up. There we're some codes so I plugged in my scanner and there was a misfire code and a camshaft position sensor fault.
 
1 - 7 of 7 Posts
Top