SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello folks,

Have been struggling with p0444 on my 9k. I juggled 3 different evap valves (2 of which I know to be good, but technically wrong p/n, the bosch 300 and 308, but I had success with 308 before). I followed the testing procedure for the manual. Valves measure ~26ohm, resistance from main relay to the valve is negligible, resistance from evap valve to ecu's pin 27 is negligible, but what's stumbling me is that I have no pin 21 on the ecu. I checked every diagram available to me and I can't find any info on it. What am I missing? Is my ECU cooked?
 

·
Registered
Joined
·
88 Posts
Stick a stethoscope or screwdriver to it and listen to see if it's clicking open/closed. Which ECU is it? I'm not familiar with the changes between 94 and 98 since I've only been researching for my 94 cde nt but I would assume it's a Jetronic LH 3.4.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
98 is trionic 5.5. The valves do open and the wiring is thoroughly tested. I tested valves on oscilloscope while using a vacuum pump as well, just to triple check.
 

·
Registered
Joined
·
88 Posts
The only thing I could think of would be a bad solder joint or corrosion on the ECU pin. The terminals on all of the circuit are tight and corrosion-free?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Yes, all connections are tight. If there was a bad solder joint, it'd likely not open the valve since pin27 grounds it when ecu commands the valve open.
 

·
Registered
Joined
·
2,015 Posts
Hello folks,

Have been struggling with p0444 on my 9k. I juggled 3 different evap valves (2 of which I know to be good, but technically wrong p/n, the bosch 300 and 308, but I had success with 308 before). I followed the testing procedure for the manual. Valves measure ~26ohm, resistance from main relay to the valve is negligible, resistance from evap valve to ecu's pin 27 is negligible, but what's stumbling me is that I have no pin 21 on the ecu. I checked every diagram available to me and I can't find any info on it. What am I missing? Is my ECU cooked?

It appears that the lead that connected to pin 21 was eliminated from that circuit by MY 1997. It was supposed to detect whether the valve was operating correctly. After that there were only two leads involved. A hot from the main relay to the solenoid coil and a ground for the other side. Looks like they decided to connect to the ECU at pin 28 or 27. The 21 pin was to be used to monitor fuel tank pressure - IDK? Read the attached it might be of some help - on the other hand it may confuse the issue even more:

 
1 - 6 of 6 Posts
Top