SaabCentral Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter · #1 ·
shortly after buying the car my upper idler failed. i replaced and then tried to fit the serp belt with no luck (didnt know about the short belt mod or that it had been done to my car by previous owner). i eventually found a belt that fit, but after a little stretch and 12k miles it was no longer tight enough so i replaced it last week with a dayco 6pk2460.

the belt fit great and there seemed to be no issues until it shredded yesterday and wrapped up around my crank pulley. a check of all pulleys and accessories turned up no failed parts. the tensioner pulley isnt quite as smooth as it could be (and i am replacing it) but i dont think it caused the belt to fail as it spins freely with almost no wobble.

is it possible i just got a bad belt? i drove the car twice after i installed it, maybe 5 miles, and it was on third trip out around 8 miles are so that it just shredded.

any thoughts?
 

·
Registered
1990 c900s > c900 Turbo
Joined
·
530 Posts
repair forum will help you more
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #3 ·
yeah i thought i had posted it there, lol. no prob though, brand new belt was warrantied out. federated looked at it and said it mustve been defective
 

·
Registered
Joined
·
2,463 Posts
It didn't cause any damage to your car did it? I would check very closely...
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #5 ·
It didn't cause any damage to your car did it? I would check very closely...
everything appears to be in great working order. i removed, inspected and cleaned the tensioner. put fresh grease in the upper idler (which is only maybe a year or two old) and tensioner pulley. i got everything back together and installed the belt and let it run for about two hours while i was working on the harness in the tailgate. seems to be no issues or major runout on any components. ill be keeping a very close eye on it though.

btw, how do we post a poll?
 
1 - 5 of 5 Posts
Top