SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all,

First time posting - hope i'm in the right place.

Have a 96 900S hatchback with 95K. Engine light was on - brought car to dealer and he fixed wiring on O2 sensor rather than replacing part. $400 and two weeks later, engine light is back on.

Assuming its the O2 sensor again, was it necessary for me to have them fix the wiring rather then fix the part (they're asking $400 for a new sensor - I know i can get it cheap online from europarts but i'm no mechanic) - Basically, I'm trying to find out whether they are ripping me off.

Any help/similar problems would be muchly appreciated.

Thanks,
S
 

·
Registered
Joined
·
10,348 Posts
Honestly I would lose this dealer. My dealer quoted me $216 for the part and $30 to install it.

Yes, fixing the wiring has worked for many people...but but....there's no parts involved?!?! What the heck did you get for that first $400?!?!?
They bascially are going to charge you a total of $800 for an o2?!?!?!

Read the FAQ (frequently asked questions) stickied above. Good thread in there regarding this very issue.
 

·
Registered
Joined
·
4 Posts
Check wwwdotlambdapower.co.uk and you'll find you sensor for arround $100.00 US, although they do sell in pounds. If the light is on, it'll wait a couple of weeks for $100.00 ;)
 

·
Registered
Joined
·
505 Posts
my cel came on, i had it read at a autozone, and it turned out to be a o2 sensor, then my DI cassette died in the parking lot there. replaced the DI cassette, and the cel came on again after about 100miles. read again, and it was an o2 sensor again. filled the car with premium, and the cel went away. been running premium since, and no more cel.

matt
 
1 - 4 of 4 Posts
Top