SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
I have a 97 2.3 LPT 9000

It has been running fine and now suddenly just won't start. There's plenty of battery power. It's just as though the immobiliser was on - but I have used the key fob alarm to disbale this.

I'm at a loss.

Anyone got ideas?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #2 ·
Just had the idea to swap the ignition cartidge with another I happened to have available. Hey presto! Started first time.


is it normal for a DI catrtridge to just completely fail like this?
 

·
Registered
Joined
·
1,150 Posts
not really.. From what i hear.. and by design... usually they start misfiring a lot first... kinda rare for them to die period... much less that spontaneously.. strannnge


-=tristan=-
 

·
Registered
Joined
·
19 Posts
I've had the same experience on a 2 litre 900 HPT. No sign of a problem until I parked the car up one morning and then tried to restart it a couple hours later....nothing. The giveaway is a strong smell of electrical insulation buring when you lift the bonnet.

The RAC carry spare SAAB DI packs in most areas because it's a common failure mode, but rarely have both the red & the black available.

If the problem is not common in the US then different suppliers may hold the answer.
 

·
Registered
Joined
·
8,293 Posts
Did you check the CPS ( Crank Positon Sensor) Mine went out this week, replaced it Sat. Had no spark, died while hot. ( Would not respart after shutting it down) Runs fine now.

I have the 9-5 but the 2.3 block all had them I think...

J
 
1 - 5 of 5 Posts
Top